summary refs log tree commit diff
path: root/gnu/packages/skarnet.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-23 15:49:00 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-23 16:00:06 +0100
commitc14dcc0c401fce569109587f908b9e99f075a959 (patch)
tree14965244f4e4a1789bc09b7c1162c96c8322cf4f /gnu/packages/skarnet.scm
parentef8cab008be6f278565258fa754164866e52aba8 (diff)
downloadguix-c14dcc0c401fce569109587f908b9e99f075a959.tar.gz
gnu: Add s6-linux-init.
This new package contains refugees from the s6-linux-utils update.

* gnu/packages/skarnet.scm (s6-linux-init): New public variable.
Diffstat (limited to 'gnu/packages/skarnet.scm')
-rw-r--r--gnu/packages/skarnet.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/skarnet.scm b/gnu/packages/skarnet.scm
index 3c6284c938..5fa442d1e9 100644
--- a/gnu/packages/skarnet.scm
+++ b/gnu/packages/skarnet.scm
@@ -290,6 +290,44 @@ performing well-known tasks such as @command{cut} and @command{grep}, but
 optimized for simplicity and small size.  They were designed for embedded
 systems and other constrained environments, but they work everywhere.")))
 
+(define-public s6-linux-init
+  (package
+   (name "s6-linux-init")
+   (version "0.3.1.1")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (string-append
+           "http://skarnet.org/software/s6-linux-init/s6-linux-init-"
+           version ".tar.gz"))
+     (sha256
+      (base32
+       "0yfxrjqlbb6kac4gcn78phxbwp5sj9jmc1vxpsrbql62mfjyiqly"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("skalibs" ,skalibs)))
+    (arguments
+     '(#:configure-flags
+       (list
+        (string-append "--with-lib="
+                       (assoc-ref %build-inputs "skalibs")
+                       "/lib/skalibs")
+        (string-append "--with-sysdeps="
+                       (assoc-ref %build-inputs "skalibs")
+                       "/lib/skalibs/sysdeps"))
+       #:tests? #f))
+    (home-page "https://skarnet.org/software/s6-linux-init")
+    (license isc)
+    (synopsis "Minimalistic tools to create an s6-based init system on Linux")
+    (description
+     " s6-linux-init is a set of minimalistic tools to create a s6-based init
+system, including an @command{/sbin/init} binary, on a Linux kernel.
+
+It is meant to automate creation of scripts revolving around the use of other
+skarnet.org tools, especially s6, in order to provide a complete booting
+environment with integrated supervision and logging without having to hand-craft
+all the details. ")))
+
 (define-public s6-linux-utils
   (package
    (name "s6-linux-utils")