summary refs log tree commit diff
path: root/gnu/packages/sml.scm
diff options
context:
space:
mode:
authorFoo Chuan Wei <chuanwei.foo@hotmail.com>2022-05-25 01:44:59 +0000
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-29 02:00:10 +0200
commit62da327848311a75723f16642c20d2925919237e (patch)
treecadae04b728e88fc5e1d891b0c5751e1366a9650 /gnu/packages/sml.scm
parented15c921395bebbe0b385ab41b1381b6ab23a42d (diff)
downloadguix-62da327848311a75723f16642c20d2925919237e.tar.gz
gnu: smlnj: Fix use of Ctrl-c in sml REPL.
* gnu/packages/sml.scm (smlnj): Replace INVOKE with SYSTEM which has
more favourable signal dispositions.

Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu/packages/sml.scm')
-rw-r--r--gnu/packages/sml.scm20
1 files changed, 16 insertions, 4 deletions
diff --git a/gnu/packages/sml.scm b/gnu/packages/sml.scm
index 1895d8eeee..368abf6cfa 100644
--- a/gnu/packages/sml.scm
+++ b/gnu/packages/sml.scm
@@ -175,10 +175,22 @@ function interface, and a symbolic debugger.")
                        "sml.boot.amd64-unix/SMLNJ-BASIS/.cm/amd64-unix/basis-common.cm"))
 
              ;; Build.
-             (invoke "./config/install.sh" "-default"
-                     (if (string=? "i686-linux" ,(%current-system))
-                       "32"
-                       "64"))
+             ;; The `sml` executable built by this package somehow inherits the
+             ;; signal dispositions of the shell where it was built. If SIGINT
+             ;; is ignored in the shell, the resulting `sml` will also ignore
+             ;; SIGINT. This will break the use of Ctrl-c for interrupting
+             ;; execution in the SML/NJ REPL.
+             ;; Here, we use Guile's `system` procedure instead of Guix's
+             ;; `invoke` because `invoke` uses Guile's `system*`, which causes
+             ;; SIGINT and SIGQUIT to be ignored.
+             (let ((exit-code
+                     (system (string-append "./config/install.sh -default "
+                                            (if (string=? "i686-linux"
+                                                          ,(%current-system))
+                                              "32"
+                                              "64")))))
+               (unless (zero? exit-code)
+                 (error (format #f "Exit code: ~a" exit-code))))
 
              ;; Undo the binary patch.
              (for-each