summary refs log tree commit diff
path: root/gnu/packages/speech.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-13 22:07:52 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-13 22:07:52 +0200
commit520cca28ee782065ecfff35efee460ab7d00a699 (patch)
tree40e5021a9e0901d2931d2c3112f6fef4a3f4d332 /gnu/packages/speech.scm
parent2bbda4f077513aa70cb10150fc1c0a808b2657ea (diff)
downloadguix-520cca28ee782065ecfff35efee460ab7d00a699.tar.gz
gnu: sonic: Don't use unstable tarball.
* gnu/packages/speech.scm (sonic)[source]: Download using git-fetch.
Diffstat (limited to 'gnu/packages/speech.scm')
-rw-r--r--gnu/packages/speech.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/speech.scm b/gnu/packages/speech.scm
index 38ae8ae6f8..21ad6f8928 100644
--- a/gnu/packages/speech.scm
+++ b/gnu/packages/speech.scm
@@ -25,6 +25,7 @@
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix utils)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
@@ -199,13 +200,14 @@ stable and well documented interface.")
     (name "sonic")
     (version "0.2.0")
     (source (origin
-             (method url-fetch)
-             (uri (string-append "https://github.com/waywardgeek/sonic/archive/"
-                                 "release-" version ".tar.gz"))
-             (file-name (string-append name "-" version ".tar.gz"))
+             (method git-fetch)
+             (uri (git-reference
+                    (url "https://github.com/waywardgeek/sonic")
+                    (commit (string-append "release-" version))))
+             (file-name (git-file-name name version))
              (sha256
               (base32
-               "11a0q9wkgbb9ymf52v7dvybfhj8hprgr67zs1xcng143fvjpr0n7"))))
+               "08xwnpw9cnaix1n1i7gvpq5hrfrqc2z1snjhjapfam506hrc77g4"))))
     (build-system gnu-build-system)
     (arguments
       `(#:tests? #f ; No test suite.