summary refs log tree commit diff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-15 00:00:08 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:48 -0400
commitd09edfec5ffc22843a6bb6df2678dc1e76ded11f (patch)
tree743d98dc8060067ad93079dad5742aa6c12a50fb /gnu/packages/sphinx.scm
parent28b602d0f664e92b6edf1f36656242a747c67d58 (diff)
downloadguix-d09edfec5ffc22843a6bb6df2678dc1e76ded11f.tar.gz
gnu: Add python-sphinx-sitemap.
* gnu/packages/sphinx.scm (python-sphinx-sitemap): New variable.
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 406fc8536b..cb1897041b 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -1052,6 +1052,25 @@ automated way to document command-line programs.  It scans
 with a simple (opinionated) workflow.")
     (license license:expat)))
 
+(define-public python-sphinx-sitemap
+  (package
+    (name "python-sphinx-sitemap")
+    (version "2.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "sphinx-sitemap" version))
+       (sha256
+        (base32 "0dvpryrz7vn8rvayzy5nrmqy4wyzlaxcx88bl46prc9w4cwxmbb5"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-sphinx))
+    (home-page "https://github.com/jdillard/sphinx-sitemap")
+    (synopsis "Sitemap generator for Sphinx")
+    (description "A Sphinx extension to generate multiversion and
+multilanguage sitemaps.org compliant sitemaps for the HTML version of your
+Sphinx documentation.")
+    (license license:expat)))
+
 (define-public python-pydata-sphinx-theme
   (package
     (name "python-pydata-sphinx-theme")