summary refs log tree commit diff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-13 11:55:51 +0200
committerMarius Bakke <marius@gnu.org>2022-08-13 19:09:14 +0200
commit00e78042b7e1e740bacb42008781548cf763d167 (patch)
tree77ee02efc7bbbcc7f731a9d069c43c9b59d7dba1 /gnu/packages/sphinx.scm
parentbe5965b1962536bebb2b3c6e2cc27b0d19da54f9 (diff)
downloadguix-00e78042b7e1e740bacb42008781548cf763d167.tar.gz
gnu: python-sphinx: Add 4.5.0.
* gnu/packages/sphinx.scm (python-sphinx-4): New variable.
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index b6e7d94462..036950e8cf 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -148,6 +148,18 @@ for Python projects or other documents consisting of multiple reStructuredText
 sources.")
     (license license:bsd-2)))
 
+;; Some packages do not support Sphinx 5 yet.  Remove when unused.
+(define-public python-sphinx-4
+  (package
+    (inherit python-sphinx)
+    (version "4.5.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "Sphinx" version))
+              (sha256
+               (base32
+                "1rp28jryxwy24y8vpacclqihbizyi6b1s6id86pibvm46ybcmy3v"))))))
+
 (define-public python-sphinxcontrib-apidoc
   (package
     (name "python-sphinxcontrib-apidoc")