summary refs log tree commit diff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-08 16:09:02 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-08 16:13:08 +0100
commit68619cad28c10d89de43e6707f31a82190972089 (patch)
treea827a02d3d7bee34143eab490b1cd9aef06183a5 /gnu/packages/sphinx.scm
parenta4a7c78f68dd86798848f86af51e71b62ce66cc1 (diff)
downloadguix-68619cad28c10d89de43e6707f31a82190972089.tar.gz
gnu: python2-sphinxcontrib-websupport: Downgrade to 1.1.2.
* gnu/packages/sphinx.scm (python2-sphinxcontrib-websupport): Downgrade to
1.1.2.
[arguments]: Override; delete 'sanity-check phase.
[propagated-inputs]: Override and add python2-six.
(python-sphinxcontrib-websupport)[properties]: Record python2-variant.
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm24
1 files changed, 22 insertions, 2 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 5fd63a617c..9093baf508 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -46,6 +46,7 @@
   #:use-module (gnu packages graphviz)
   #:use-module (gnu packages image)
   #:use-module (gnu packages imagemagick)
+  #:use-module (gnu packages python)
   #:use-module (gnu packages python-build)
   #:use-module (gnu packages python-crypto)
   #:use-module (gnu packages python-web)
@@ -407,10 +408,29 @@ builder does not support SVG images natively (e.g. LaTeX).")
     (description "This package provides a Python API to easily integrate
 Sphinx documentation into your web application.  It provides tools to
 integrate Sphinx documents in web templates and to handle searches.")
-    (license license:bsd-3)))
+    (license license:bsd-3)
+    (properties `((python2-variant . ,(delay python2-sphinxcontrib-websupport))))))
 
+;; 1.1.2 is the last version to support Python 2.
 (define-public python2-sphinxcontrib-websupport
-  (package-with-python2 python-sphinxcontrib-websupport))
+  (package
+    (inherit (package-with-python2
+              (strip-python2-variant python-sphinxcontrib-websupport)))
+    (version "1.1.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "sphinxcontrib-websupport" version))
+              (sha256
+               (base32
+                "1z7fqra0xm1cdp8vvp80fcvnjlywym7bzz80m0liq7fz1zxvw08m"))))
+    (arguments
+     `(#:tests? #f
+       #:python ,python-2
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'sanity-check))))
+    (propagated-inputs
+     `(("python2-six" ,python2-six)))))
 
 (define-public python-sphinx-gallery
   (package