summary refs log tree commit diff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2021-03-03 22:05:07 -0600
committerEric Bavier <bavier@member.fsf.org>2021-03-14 13:24:21 -0500
commit207aa62e6ba476ecefd101ba7643b5afa9c1de20 (patch)
treeb6299890b6ca1debcdfb75de04f135e95d203981 /gnu/packages/sphinx.scm
parentb15720182e393bc26e9d61ea4d7534b7eea19390 (diff)
downloadguix-207aa62e6ba476ecefd101ba7643b5afa9c1de20.tar.gz
gnu: Add python-sphinx-autodoc-typehints.
* gnu/packages/sphinx.scm (python-sphinx-autodoc-typehints): New variable.
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 29872ed942..1704cbce59 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -670,6 +670,33 @@ documentation when a change is detected.  It also includes a livereload
 enabled web server.")
     (license license:expat)))
 
+(define-public python-sphinx-autodoc-typehints
+  (package
+    (name "python-sphinx-autodoc-typehints")
+    (version "1.11.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "sphinx-autodoc-typehints" version))
+       (sha256
+        (base32
+         "086v9mg21pvfx0lfqjx2xf36hnzrsripfg345xi59f7xwb9scjr4"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-setuptools-scm" ,python-setuptools-scm)
+       ("python-sphinx" ,python-sphinx)))
+    (native-inputs
+     `(("python-dataclasses" ,python-dataclasses)
+       ("python-pytest" ,python-pytest)
+       ("python-sphinx" ,python-sphinx)
+       ("python-sphobjinv" ,python-sphobjinv)
+       ("python-typing-extensions" ,python-typing-extensions)))
+    (home-page "https://pypi.org/project/sphinx-autodoc-typehints/")
+    (synopsis "Type hints for the Sphinx autodoc extension")
+    (description "This extension allows you to use Python 3 annotations for
+documenting acceptable argument types and return value types of functions.")
+    (license license:expat)))
+
 (define-public python-nbsphinx
   (package
     (name "python-nbsphinx")