summary refs log tree commit diff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-12 23:00:22 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-13 00:44:57 +0200
commitbcb22b3624e677231b50029fea63e3b6e4978b2d (patch)
treea532593999d68e935ef50fd1c823768479f9ade5 /gnu/packages/sphinx.scm
parent5ea654cfe030165efadf1f1dcfb2adef66a1f44f (diff)
downloadguix-bcb22b3624e677231b50029fea63e3b6e4978b2d.tar.gz
gnu: Add python-sphinx-copybutton.
* gnu/packages/sphinx.scm (python-sphinx-copybutton): New variable.
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm21
1 files changed, 20 insertions, 1 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 5ec769388a..9bd1e8d421 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 David Thompson <davet@gnu.org>
-;;; Copyright © 2015, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2015, 2016, 2017 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2016, 2017, 2018, 2019 Marius Bakke <mbakke@fastmail.com>
@@ -163,6 +163,25 @@ sources.")
 Apple help books.")
     (license license:bsd-2)))
 
+(define-public python-sphinx-copybutton
+  (package
+    (name "python-sphinx-copybutton")
+    (version "0.2.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "sphinx-copybutton" version))
+       (sha256
+        (base32
+         "1bk006nv5s9ym6v67cxd4d2wvd8wm6czqi21mqcs33risygksncl"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/choldgraf/sphinx-copybutton")
+    (synopsis "Sphinx extension to add \"copy\" buttons to code blocks")
+    (description
+     "This package provides a small sphinx extension to add \"copy\" buttons
+to code blocks.")
+    (license license:expat)))
+
 (define-public python-sphinxcontrib-devhelp
   (package
     (name "python-sphinxcontrib-devhelp")