summary refs log tree commit diff
path: root/gnu/packages/spice.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-06-17 12:57:02 +0200
committerMarius Bakke <marius@gnu.org>2021-06-19 17:08:38 +0200
commit02bf9bab8b575f3c90a7631140619fec9114853e (patch)
treefb81950409a17ab700a183d7e87e55280521043e /gnu/packages/spice.scm
parentbe78dea4d3fdd1bf5ad7b7d69d7200fca1c65f59 (diff)
downloadguix-02bf9bab8b575f3c90a7631140619fec9114853e.tar.gz
gnu: spice: Adjust for newer GLib.
* gnu/packages/spice.scm (spice)[arguments]: Set XDG_CONFIG_HOME before
running the tests.
Diffstat (limited to 'gnu/packages/spice.scm')
-rw-r--r--gnu/packages/spice.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index c1e9e173a2..a6a87cac75 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -252,6 +252,14 @@ which allows users to view a desktop computing environment.")
         '("--enable-lz4"
           "--enable-automated-tests")
 
+        #:phases
+        (modify-phases %standard-phases
+          ;; XXX: Otherwise the server listen tests fails with
+          ;;   Failed to create /homeless-shelter/.config/glib-2.0/settings
+          (add-before 'check 'set-XDG_CONFIG_HOME
+            (lambda _
+              (setenv "XDG_CONFIG_HOME" "/tmp"))))
+
         ;; Several tests appear to be opening the same sockets concurrently.
         #:parallel-tests? #f))
     (synopsis "Server implementation of the SPICE protocol")