summary refs log tree commit diff
path: root/gnu/packages/spice.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2024-08-18 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2024-08-18 02:00:00 +0200
commited4e0b48f16530def08862657301178b5cf00a9a (patch)
tree12bcbdb18a09d54bda350c3cb6060e381e539706 /gnu/packages/spice.scm
parented3649bcce1ea0db5385744f9114d4b40d6dce55 (diff)
downloadguix-ed4e0b48f16530def08862657301178b5cf00a9a.tar.gz
Replace some more occurrences of ‘setuid-programs’.
* gnu/packages/containers.scm (podman, buildah)[arguments]:
Substitute /run/privileged/bin for /run/setuid-programs.
* gnu/packages/mail.scm (opensmtpd)[arguments]: Likewise.
* gnu/packages/spice.scm (spice-gtk)[arguments]: Likewise.
* gnu/packages/patches/enlightenment-fix-setuid-path.patch: Likewise.
* gnu/packages/xdisorg.scm (xsecurelock)[description]: Rewrite
example code to use the ‘privileged-program(s)’ terminology.
* doc/guix-cookbook.texi (Network bridge for QEMU): Likewise.
* gnu/packages/disk.scm (udevil)[arguments]: Update a comment.

Change-Id: I7f467e8743a3ef556cd89bac41509bf51d9edb30
Diffstat (limited to 'gnu/packages/spice.scm')
-rw-r--r--gnu/packages/spice.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index 860b77cf5d..5c7b9c1674 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -172,7 +172,7 @@ which allows users to view a desktop computing environment.")
               ;; variable.
               (substitute* "src/usb-acl-helper.c"
                 (("ACL_HELPER_PATH\"/spice-client-glib-usb-acl-helper\"")
-                 "\"/run/setuid-programs/spice-client-glib-usb-acl-helper\""))))
+                 "\"/run/privileged/bin/spice-client-glib-usb-acl-helper\""))))
           (add-before 'configure 'correct-polkit-dir
             (lambda _
               (substitute* "meson.build"