summary refs log tree commit diff
path: root/gnu/packages/spice.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-08-17 23:21:00 -0400
committerLeo Famulari <leo@famulari.name>2016-08-17 23:35:22 -0400
commit015ee84aac888b3900fa0ee54a1b7e55c083e7d3 (patch)
tree2ef7a51321dff53e479bc6d11f3785e1c65c07f0 /gnu/packages/spice.scm
parenta3d6e1f432ad5f9cde8bee670b28646e05c4cb19 (diff)
parent79f9d5d5dc97e492e0583e039a2699aa17f4eb11 (diff)
downloadguix-015ee84aac888b3900fa0ee54a1b7e55c083e7d3.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/spice.scm')
-rw-r--r--gnu/packages/spice.scm72
1 files changed, 49 insertions, 23 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index 9e4a6695ac..3e6366e6c0 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -18,6 +18,7 @@
 
 (define-module (gnu packages spice)
   #:use-module (gnu packages)
+  #:use-module (gnu packages autotools) ; remove after updating usbredir to 0.7.1+
   #:use-module (gnu packages compression)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
@@ -37,34 +38,59 @@
   #:use-module (gnu packages xml)
   #:use-module (guix build-system gnu)
   #:use-module (guix download)
+  #:use-module (guix git-download) ; remove after updating usbredir to 0.7.1+
   #:use-module (guix packages)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix utils))
 
 (define-public usbredir
-  (package
-    (name "usbredir")
-    (version "0.7.1")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                "http://spice-space.org/download/usbredir/"
-                "usbredir-" version ".tar.bz2"))
-              (sha256
-               (base32
-                "1wsnmk4wjpdhbn1zaxg6bmyxspcki2zgy0am9lk037rnl4krwzj0"))))
-    (build-system gnu-build-system)
-    (propagated-inputs
-      `(("libusb" ,libusb)))
-    (native-inputs
-      `(("pkg-config" ,pkg-config)))
-    (synopsis "Tools for sending USB device traffic over a network")
-    (description "Usbredir is a network protocol for sending USB device traffic
-over a network connection.  It can be used to redirect traffic from a USB device
-to a different (virtual) machine than the one to which the USB device is
-attached.")
-    (home-page "http://www.spice-space.org")
-    (license (list license:gpl2+ license:lgpl2.0+ license:lgpl2.1+))))
+  (let ((commit "ac80a5971c6318d73d5fba4b5f13d3a9389558c9")
+        (revision "1"))          ;Guix package revision
+    (package
+      (name "usbredir")
+      (version (string-append "0.7.1-" revision "."
+                              (string-take commit 7)))
+      ;(version "0.7.1")
+      ;(source (origin
+      ;          (method url-fetch)
+      ;          (uri (string-append
+      ;            "http://spice-space.org/download/usbredir/"
+      ;            "usbredir-" version ".tar.bz2"))
+      ;          (sha256
+      ;           (base32
+      ;            "1wsnmk4wjpdhbn1zaxg6bmyxspcki2zgy0am9lk037rnl4krwzj0"))))
+      ; FIXME: usbredir 0.7.1 release doesn't build on 32 bit systems.
+      ;        issue is fixed in HEAD
+      ;        remove 'autogen phase and autoconf, automake, libtool inputs
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                        (url "http://cgit.freedesktop.org/spice/usbredir")
+                        (commit commit)))
+                (sha256
+                 (base32
+                  "052fywgi72j68dr5ybldncg4vk8iqfrh58la7iazyxxpph9aag1g"))))
+      (build-system gnu-build-system)
+      (propagated-inputs
+        `(("libusb" ,libusb)))
+      (native-inputs
+        `(("pkg-config" ,pkg-config)
+          ("autoconf" ,autoconf)
+          ("automake" ,automake)
+          ("libtool" ,libtool)))
+      (arguments
+       `(#:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'autogen
+             (lambda _
+               (zero? (system* "autoreconf" "-vfi")))))))
+      (synopsis "Tools for sending USB device traffic over a network")
+      (description "Usbredir is a network protocol for sending USB device traffic
+  over a network connection.  It can be used to redirect traffic from a USB device
+  to a different (virtual) machine than the one to which the USB device is
+  attached.")
+      (home-page "http://www.spice-space.org")
+      (license (list license:gpl2+ license:lgpl2.0+ license:lgpl2.1+)))))
 
 (define-public virglrenderer
   (package