summary refs log tree commit diff
path: root/gnu/packages/spice.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-12-03 19:15:17 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-12-03 19:15:17 +0100
commit99f63f011df2aab38e98d7ee4608a8c70bf74c4d (patch)
tree3f224028f30c60f2ed7b9846365ad926192fc7e9 /gnu/packages/spice.scm
parente9a8b603337802a77ff2d68f0d30dc0e67721e3a (diff)
parent4f03aa23e805bd653de774e1d74ed2f50826899b (diff)
downloadguix-99f63f011df2aab38e98d7ee4608a8c70bf74c4d.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/spice.scm')
-rw-r--r--gnu/packages/spice.scm102
1 files changed, 40 insertions, 62 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index 69bc2b82cb..94e6aa8438 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -19,7 +19,6 @@
 
 (define-module (gnu packages spice)
   #:use-module (gnu packages)
-  #:use-module (gnu packages autotools) ; remove after updating usbredir to 0.7.1+
   #:use-module (gnu packages compression)
   #:use-module (gnu packages cyrus-sasl)
   #:use-module (gnu packages gl)
@@ -40,64 +39,33 @@
   #:use-module (gnu packages xml)
   #:use-module (guix build-system gnu)
   #:use-module (guix download)
-  #:use-module (guix git-download) ; remove after updating usbredir to 0.7.1+
   #:use-module (guix packages)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix utils))
 
 (define-public usbredir
-  (let ((commit "ac80a5971c6318d73d5fba4b5f13d3a9389558c9")
-        (revision "1"))          ;Guix package revision
-    (package
-      (name "usbredir")
-      (version (string-append "0.7.1-" revision "."
-                              (string-take commit 7)))
-      ;(version "0.7.1")
-      ;(source (origin
-      ;          (method url-fetch)
-      ;          (uri (string-append
-      ;            "http://spice-space.org/download/usbredir/"
-      ;            "usbredir-" version ".tar.bz2"))
-      ;          (sha256
-      ;           (base32
-      ;            "1wsnmk4wjpdhbn1zaxg6bmyxspcki2zgy0am9lk037rnl4krwzj0"))))
-      ; FIXME: usbredir 0.7.1 release doesn't build on 32 bit systems.
-      ;        issue is fixed in HEAD
-      ;        remove 'autogen phase and autoconf, automake, libtool inputs
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                        (url "https://anongit.freedesktop.org/git/spice/usbredir.git")
-                        (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "052fywgi72j68dr5ybldncg4vk8iqfrh58la7iazyxxpph9aag1g"))))
-      (build-system gnu-build-system)
-      (propagated-inputs
-        `(("libusb" ,libusb)))
-      (native-inputs
-        `(("pkg-config" ,pkg-config)
-          ("autoconf" ,autoconf)
-          ("automake" ,automake)
-          ("libtool" ,libtool)))
-      (arguments
-       `(#:phases
-         (modify-phases %standard-phases
-           (add-after 'unpack 'autogen
-             (lambda _
-               ;; Build without '-Werror', in particular to avoid errors due
-               ;; to the use of the deprecated 'libusb_set_debug' function.
-               (substitute* "configure.ac"
-                 (("-Werror") ""))
-               (zero? (system* "autoreconf" "-vfi")))))))
-      (synopsis "Tools for sending USB device traffic over a network")
-      (description "Usbredir is a network protocol for sending USB device traffic
-  over a network connection.  It can be used to redirect traffic from a USB device
-  to a different (virtual) machine than the one to which the USB device is
-  attached.")
-      (home-page "https://www.spice-space.org")
-      (license (list license:gpl2+ license:lgpl2.0+ license:lgpl2.1+)))))
+  (package
+    (name "usbredir")
+    (home-page "https://spice-space.org")
+    (version "0.8.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append home-page "/download/" name "/" name "-"
+                                  version ".tar.bz2"))
+              (sha256
+               (base32
+                "002yik1x7kn0427xahvnhjby2np14a6xqw7c3dx530n9h5d9rg47"))))
+    (build-system gnu-build-system)
+    (propagated-inputs
+     `(("libusb" ,libusb)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (synopsis "Tools for sending USB device traffic over a network")
+    (description
+     "Usbredir is a network protocol for sending USB device traffic over a
+network connection.  It can be used to redirect traffic from a USB device to a
+different (virtual) machine than the one to which the USB device is attached.")
+    (license (list license:gpl2+ license:lgpl2.0+ license:lgpl2.1+))))
 
 (define-public virglrenderer
   (package
@@ -209,15 +177,15 @@ which allows users to view a desktop computing environment.")
 (define-public spice
   (package
     (name "spice")
-    (version "0.14.0")
+    (version "0.14.1")
     (source (origin
               (method url-fetch)
               (uri (string-append
                 "https://www.spice-space.org/download/releases/"
-                "spice-" version ".tar.bz2"))
+                "spice-server/spice-" version ".tar.bz2"))
               (sha256
                (base32
-                "0j5q7cp5p95jk8fp48gz76rz96lifimdsx1wnpmfal0nnnar9nrs"))))
+                "068mb9l7wzk4k4c65bzvpw5fyyzh81rb6z81skgdxvh67pk5vb8y"))))
     (build-system gnu-build-system)
     (propagated-inputs
       `(("openssl" ,openssl)
@@ -234,12 +202,22 @@ which allows users to view a desktop computing environment.")
     (native-inputs
       `(("pkg-config" ,pkg-config)
         ("python" ,python)
-        ("spice-gtk" ,spice-gtk)))
+        ("spice-gtk" ,spice-gtk)
+
+        ;; These are needed for the server listen tests.
+        ("glib-networking" ,glib-networking)
+        ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
     (arguments
       `(#:configure-flags
-        '("--disable-celt051" ; Disable support for unpackaged audio codec
-          "--enable-lz4"
-          "--enable-automated-tests")))
+        '("--enable-lz4"
+          "--enable-automated-tests")
+
+        ;; Several tests appear to be opening the same sockets concurrently.
+        #:parallel-tests? #f
+
+        #:phases (modify-phases %standard-phases
+                   (add-before 'check 'use-empty-ssl-cert-file
+                     (lambda _ (setenv "SSL_CERT_FILE" "/dev/null") #t)))))
     (synopsis "Server implementation of the SPICE protocol")
     (description "SPICE is a remote display system built for virtual
 environments which allows you to view a computing 'desktop' environment
@@ -276,7 +254,7 @@ Internet and from a wide variety of machine architectures.")
          (add-after 'unpack 'patch-spice-vdagent.desktop
            (lambda* (#:key outputs #:allow-other-keys)
             (substitute* "data/spice-vdagent.desktop"
-              (("Exec=/usr/bin/spice-vdagent\n")
+              (("Exec=/usr/bin/spice-vdagent")
                (string-append "Exec=" (assoc-ref outputs "out")
                               "/bin/spice-vdagent")))
              #t)))))