summary refs log tree commit diff
path: root/gnu/packages/spice.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-16 10:44:30 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-25 14:46:52 -0500
commit7b64e57c4c5eeb539fce45ca030c7ec708611894 (patch)
treefdcc852f6a4cf805f42176b5ec9d5266de85a0a7 /gnu/packages/spice.scm
parent0d07629295b5e9a0f170640b1aa741ffc3b1153c (diff)
downloadguix-7b64e57c4c5eeb539fce45ca030c7ec708611894.tar.gz
gnu: virglrenderer: Update to 0.7.0.
* gnu/packages/spice.scm (virglrenderer): Update to 0.7.0.  Remove
patch. Re-indent and sort inputs.
* gnu/packages/patches/virglrenderer-CVE-2017-6386.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): De-register it.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/spice.scm')
-rw-r--r--gnu/packages/spice.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index fc63b7228f..46bb9844f2 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -84,21 +84,18 @@ different (virtual) machine than the one to which the USB device is attached.")
 (define-public virglrenderer
   (package
     (name "virglrenderer")
-    (version "0.6.0")
+    (version "0.7.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
                 "https://www.freedesktop.org/software/virgl/"
                 "virglrenderer-" version ".tar.bz2"))
-              (patches (search-patches "virglrenderer-CVE-2017-6386.patch"))
               (sha256
                (base32
-                "06kf0q4l52gzx5p63l8850hff8pmhp7xv1hk8zgx2apbw18y6jd5"))))
+                "041agg1d6i8hg250y30f08n3via0hs9rbijxdrfifb8ara805v0m"))))
     (build-system gnu-build-system)
-    (inputs
-      (list libepoxy mesa eudev))
-    (native-inputs
-      (list pkg-config))
+    (inputs (list eudev libepoxy mesa))
+    (native-inputs (list pkg-config))
     (synopsis "Virtual 3D GPU library")
     (description "A virtual 3D GPU library that enables a virtualized operating
 system to use the host GPU to accelerate 3D rendering.")