summary refs log tree commit diff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-06 10:54:41 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-06 10:56:01 +0100
commit9478a252509a93f3e7f486cbc549631185ba071d (patch)
tree07796f6c47190dcc10cebc36bce3ad70fc56a7a5 /gnu/packages/ssh.scm
parent93e9f0bc7fc97db7b9e31477858ef7cb2ce01c90 (diff)
downloadguix-9478a252509a93f3e7f486cbc549631185ba071d.tar.gz
gnu: openssh: Remove libfido2 dependency on GNU/Hurd.
* gnu/packages/ssh.scm (openssh)[inputs]: Remove LIBFIDO2 when
'hurd-target?'.
[arguments]: Likewise for "--with-security-key-builtin".
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm17
1 files changed, 10 insertions, 7 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 616f6dc915..e8c7a92199 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012-2021 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2015, 2016, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
@@ -200,11 +200,11 @@ a server that supports the SSH-2 protocol.")
    (native-inputs `(("groff" ,groff)
                     ("pkg-config" ,pkg-config)))
    (inputs `(("libedit" ,libedit)
-             ("libfido2" ,libfido2)
              ("openssl" ,openssl)
              ,@(if (hurd-target?)
-                 '()
-                 `(("pam" ,linux-pam)))
+                   '()
+                   `(("pam" ,linux-pam)
+                     ("libfido2" ,libfido2)))     ;fails to build on GNU/Hurd
              ("mit-krb5" ,mit-krb5)
              ("zlib" ,zlib)
              ("xauth" ,xauth)))        ; for 'ssh -X' and 'ssh -Y'
@@ -229,10 +229,13 @@ a server that supports the SSH-2 protocol.")
                           ;; Enable PAM support in sshd.
                           ,,@(if (hurd-target?)
                                '()
-                               '("--with-pam"))
+                               '("--with-pam"
+
+                                 ;; Support creation and use of ecdsa-sk,
+                                 ;; ed25519-sk keys.
+                                 "--with-security-key-builtin"))
+
 
-                          ;; supports creation and use of ecdsa-sk, ed25519-sk keys
-                          "--with-security-key-builtin"
 
                           ;; "make install" runs "install -s" by default,
                           ;; which doesn't work for cross-compiled binaries