summary refs log tree commit diff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-08-01 15:19:38 +0200
committerLudovic Courtès <ludo@gnu.org>2017-08-01 15:32:07 +0200
commit04b6d6f7f7a73e39dcff1e2bca3113ea567e2944 (patch)
treec9f9ab3a8c32f7decd9c5b80cfc3f0894d95df6d /gnu/packages/ssh.scm
parent12235a124f7fc56d9cd4eaf76a453cf55d3026ea (diff)
downloadguix-04b6d6f7f7a73e39dcff1e2bca3113ea567e2944.tar.gz
gnu: guile-ssh: Update to 0.11.2.
* gnu/packages/ssh.scm (guile-ssh): Update to 0.11.2.
[source]: Remove 'patches', 'modules', and 'snippet'.
* gnu/packages/patches/guile-ssh-channel-finalization.patch,
gnu/packages/patches/guile-ssh-double-free.patch,
gnu/packages/patches/guile-ssh-rexec-bug.patch: Remove.
* gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm16
1 files changed, 2 insertions, 14 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 22737b7aec..55689a6c6d 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -215,7 +215,7 @@ Additionally, various channel-specific options can be negotiated.")
 (define-public guile-ssh
   (package
     (name "guile-ssh")
-    (version "0.11.0")
+    (version "0.11.2")
     (home-page "https://github.com/artyom-poptsov/guile-ssh")
     (source (origin
               ;; ftp://memory-heap.org/software/guile-ssh/guile-ssh-VERSION.tar.gz
@@ -227,19 +227,7 @@ Additionally, various channel-specific options can be negotiated.")
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "0r261i8kc3avbmbwgyzak2vnqwssjlgz37g2y2fwm80w9bmn2m7j"))
-              (patches (search-patches "guile-ssh-rexec-bug.patch"
-                                       "guile-ssh-double-free.patch"
-                                       "guile-ssh-channel-finalization.patch"))
-              (modules '((guix build utils)))
-              (snippet
-               ;; 'configure.ac' mistakenly tries to link files from examples/
-               ;; that are not instantiated yet.  Work around it.
-               '(substitute* "configure.ac"
-                  (("AC_CONFIG_LINKS\\(\\[examples/([^:]+):.*" _ file)
-                   (string-append "AC_CONFIG_FILES([examples/" file
-                                  "], [chmod +x examples/"
-                                  file "])\n"))))))
+                "1w0k5s09xj5xycb7lbp5b7rm0xncclms3jwl98lwj8fxwngi1s90"))))
     (build-system gnu-build-system)
     (outputs '("out" "debug"))
     (arguments