summary refs log tree commit diff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-05-19 10:50:20 +0200
committerLudovic Courtès <ludo@gnu.org>2017-05-19 10:50:20 +0200
commite7fbd49132406bb9ec12141ac77ac401f58ee267 (patch)
treec11fc06d12dba52e12f596fba146cc287e09826d /gnu/packages/ssh.scm
parent7afc2aabdf2041faac1d1adfc5752f1e92d29822 (diff)
downloadguix-e7fbd49132406bb9ec12141ac77ac401f58ee267.tar.gz
gnu: guile-ssh: Fix potential double-free/use-after-free issue.
Fixes <http://bugs.gnu.org/26976>.
Reported by Mark H Weaver <mhw@netris.org>.

* gnu/packages/patches/guile-ssh-double-free.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/ssh.scm (guile-ssh)[source](patches): Add it.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 6a074d10fa..bb1898774b 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -226,7 +226,8 @@ Additionally, various channel-specific options can be negotiated.")
               (sha256
                (base32
                 "0r261i8kc3avbmbwgyzak2vnqwssjlgz37g2y2fwm80w9bmn2m7j"))
-              (patches (search-patches "guile-ssh-rexec-bug.patch"))
+              (patches (search-patches "guile-ssh-rexec-bug.patch"
+                                       "guile-ssh-double-free.patch"))
               (modules '((guix build utils)))
               (snippet
                ;; 'configure.ac' mistakenly tries to link files from examples/