summary refs log tree commit diff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-03-01 12:21:54 +0100
committerLudovic Courtès <ludo@gnu.org>2022-03-01 12:33:07 +0100
commiteabc6af9b8b14bd629544e54bc9c9afa2d0dcd85 (patch)
treee255aca3308139e1ad8badd9d12129830f07f057 /gnu/packages/ssh.scm
parent60c45fd9fd1732b3905a0c3a134878e24592c4b5 (diff)
downloadguix-eabc6af9b8b14bd629544e54bc9c9afa2d0dcd85.tar.gz
gnu: guile-ssh: Update to 0.15.1.
* gnu/packages/patches/guile-ssh-fix-test-suite.patch,
gnu/packages/patches/guile-ssh-read-error.patch: Remove.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/ssh.scm (guile-ssh): Update to 0.15.1, and remove those
patches.
(guile2.2-ssh)[source]: Remove.
(guile2.0-ssh): Remove.

Co-authored-by: poptsov.artyom@gmail.com (Artyom V. Poptsov)
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm24
1 files changed, 2 insertions, 22 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 7c8b09879f..9895cb24af 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -310,7 +310,7 @@ Additionally, various channel-specific options can be negotiated.")
 (define-public guile-ssh
   (package
     (name "guile-ssh")
-    (version "0.13.1")
+    (version "0.15.1")
     (home-page "https://github.com/artyom-poptsov/guile-ssh")
     (source (origin
               (method git-fetch)
@@ -320,9 +320,7 @@ Additionally, various channel-specific options can be negotiated.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1xpxkvgj7wgcl450djkcrmrf957mcy2f36hfs5g6kpla1gax2d1g"))
-              (patches (search-patches "guile-ssh-fix-test-suite.patch"
-                                       "guile-ssh-read-error.patch"))))
+                "0zzn5hsf97b35gixyg4z14sspl15qwnp52y4h89wra4y31l7467q"))))
     (build-system gnu-build-system)
     (outputs '("out" "debug"))
     (arguments
@@ -382,28 +380,10 @@ programs written in GNU Guile interpreter.  It is a wrapper to the underlying
 libssh library.")
     (license license:gpl3+)))
 
-(define-public guile2.0-ssh
-  (package
-    (inherit guile-ssh)
-    (name "guile2.0-ssh")
-    (source (origin
-              (inherit (package-source guile-ssh))
-              (patches (search-patches "guile-ssh-fix-test-suite.patch"))))
-    (native-inputs
-     (modify-inputs (package-native-inputs guile-ssh)
-       (delete "guile")
-       (prepend guile-2.0 ;needed when cross-compiling.
-                )))
-    (inputs (modify-inputs (package-inputs guile-ssh)
-              (replace "guile" guile-2.0)))))
-
 (define-public guile2.2-ssh
   (package
     (inherit guile-ssh)
     (name "guile2.2-ssh")
-    (source (origin
-              (inherit (package-source guile-ssh))
-              (patches (search-patches "guile-ssh-fix-test-suite.patch"))))
     (native-inputs
      (modify-inputs (package-native-inputs guile-ssh)
        (delete "guile")