summary refs log tree commit diff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-03-25 16:14:45 +0100
committerLudovic Courtès <ludo@gnu.org>2014-03-25 18:54:53 +0100
commitafde8da3f244ce9655ebd72a89a21ab8913f8ce1 (patch)
treebdc41bb96f9fc9087a94a3f3fba6c719acc7b1ba /gnu/packages/ssh.scm
parentb8c291fc88855820c2cce57372b378a95448ebdf (diff)
downloadguix-afde8da3f244ce9655ebd72a89a21ab8913f8ce1.tar.gz
gnu: guile-ssh: Upgrade to 0.6.0.
* gnu/packages/ssh.scm (guile-ssh): Upgrade to 0.6.0.
  [arguments]: Remove #:tests? #f; add #:parallel-build? #f.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 43c1b6e90b..78611b1767 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -187,7 +187,7 @@ Additionally, various channel-specific options can be negotiated.")
 (define-public guile-ssh
   (package
     (name "guile-ssh")
-    (version "0.5.0")
+    (version "0.6.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -195,7 +195,7 @@ Additionally, various channel-specific options can be negotiated.")
                     version ".tar.gz"))
               (sha256
                (base32
-                "13wk2fj08b8zjylvf78l3d9pf8y3zqcd7h75jf15a46iprk00n7q"))))
+                "1v4y5vrwg0g6804pzbr160zahlqvj7k7iwys2bdpfzp7m2i47siq"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases (alist-cons-before
@@ -227,11 +227,11 @@ Additionally, various channel-specific options can be negotiated.")
                                               (assoc-ref %outputs "out")
                                               "/share/guile/site/2.0"))
 
-       ;; Two client/server tests use the same port.
-       #:parallel-tests? #f
+       ;; Building the .go requires building libguile-ssh.so first.
+       #:parallel-build? #f
 
-       ;; XXX: There are test failures reported and being fixed.
-       #:tests? #f))
+       ;; Tests are not parallel-safe.
+       #:parallel-tests? #f))
     (native-inputs `(("autoconf" ,autoconf)
                      ("automake" ,automake)
                      ("libtool" ,libtool "bin")