summary refs log tree commit diff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-26 11:35:26 +0200
committerMarius Bakke <marius@gnu.org>2022-06-26 12:06:31 +0200
commit9a94370c213a60c38890bb1c7616979d83b57b27 (patch)
treea378311a91a7063001341ca6c3c5b42ee5ef0a47 /gnu/packages/ssh.scm
parent09a3f7c6fcbb5c63ecd402daef7fd9714d3720d3 (diff)
downloadguix-9a94370c213a60c38890bb1c7616979d83b57b27.tar.gz
gnu: libssh2: Omit static library.
* gnu/packages/ssh.scm (libssh2)[arguments]: Add "--disable-static" in
 #:configure-flags.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index db1aa0d595..e459ca7b33 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -172,7 +172,9 @@ applications.")
    ;; The installed libssh2.pc file does not include paths to libgcrypt and
    ;; zlib libraries, so we need to propagate the inputs.
    (propagated-inputs (list libgcrypt zlib))
-   (arguments `(#:configure-flags `("--with-libgcrypt")))
+   (arguments
+    (list #:configure-flags #~'("--with-libgcrypt"
+                                "--disable-static")))
    (synopsis "Client-side C library implementing the SSH2 protocol")
    (description
     "libssh2 is a library intended to allow software developers access to