summary refs log tree commit diff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-20 23:13:00 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-21 17:24:29 +0200
commite2c7b7bb68594c2f4f3a13e98da1e32509a080a5 (patch)
treefbfaac110cc816e6ab1dffcf9c659b417f15531d /gnu/packages/ssh.scm
parent7b0faf32e955ce3af6defae696e0406624a40bdc (diff)
downloadguix-e2c7b7bb68594c2f4f3a13e98da1e32509a080a5.tar.gz
gnu: libssh2: MIPS workaround no longer is.
* gnu/packages/ssh.scm (libssh2)[arguments]: Override the 'bootstrap' phase
regardless of target system.  Remove 'autoreconf' phase.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm21
1 files changed, 4 insertions, 17 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index faa09e94c3..e09bfbde6f 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -117,23 +117,10 @@ remote applications.")
    (propagated-inputs `(("libgcrypt" ,libgcrypt)
                         ("zlib" ,zlib)))
    (arguments `(#:configure-flags `("--with-libgcrypt")
-                #:phases
-                ;; FIXME: In the next core-updates cycle, replace the entire
-                ;; following ,(...) form with its first 'modify-phases'
-                ;; subform.  The change made here is only strictly needed on
-                ;; MIPS, but should work on any system.  For now, we apply it
-                ;; only to MIPS to avoid forcing thousands of rebuilds on
-                ;; other systems.
-                ,(if (string-prefix? "mips" (or (%current-target-system)
-                                                (%current-system)))
-                     '(modify-phases %standard-phases
-                        (replace 'bootstrap
-                          (lambda _
-                            (invoke "autoreconf" "-v"))))
-                     '(modify-phases %standard-phases
-                        (add-before 'configure 'autoreconf
-                          (lambda _
-                            (invoke "autoreconf" "-v")))))))
+                #:phases (modify-phases %standard-phases
+                           (replace 'bootstrap
+                             (lambda _
+                               (invoke "autoreconf" "-v"))))))
    (native-inputs `(("autoconf" ,autoconf)
                     ("automake" ,automake)))
    (synopsis "Client-side C library implementing the SSH2 protocol")