summary refs log tree commit diff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-06-13 23:20:25 +0200
committerLudovic Courtès <ludo@gnu.org>2017-06-13 23:22:19 +0200
commit8e469b67f95cfe5b95405b503b8ee315fdf8ce66 (patch)
tree851fef8a3231b0dec9cbb40a8e8e7b7876764cfb /gnu/packages/ssh.scm
parent4e863eb35fd8337eab48928e7733b7f6b7b2c242 (diff)
downloadguix-8e469b67f95cfe5b95405b503b8ee315fdf8ce66.tar.gz
gnu: guile-ssh: Close RREPL channel ports before they are finalized.
Partly fixes <https://bugs.gnu.org/26976>.

* gnu/packages/patches/guile-ssh-channel-finalization.patch: New file.
* gnu/packages/ssh.scm (guile-ssh)[source](patches): Use it.
* gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index d79663a2b5..d03686c11c 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -229,7 +229,8 @@ Additionally, various channel-specific options can be negotiated.")
                (base32
                 "0r261i8kc3avbmbwgyzak2vnqwssjlgz37g2y2fwm80w9bmn2m7j"))
               (patches (search-patches "guile-ssh-rexec-bug.patch"
-                                       "guile-ssh-double-free.patch"))
+                                       "guile-ssh-double-free.patch"
+                                       "guile-ssh-channel-finalization.patch"))
               (modules '((guix build utils)))
               (snippet
                ;; 'configure.ac' mistakenly tries to link files from examples/