summary refs log tree commit diff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-05-17 01:46:25 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-05-17 01:48:25 +0200
commit1be06ddac1669ede23e0d282c8fc728cca5d4974 (patch)
tree350995dab4ba9bf0a93b5216065639bd98ed2d3f /gnu/packages/ssh.scm
parentae113b976bfb71168a737c6a9a82cd87782077d0 (diff)
downloadguix-1be06ddac1669ede23e0d282c8fc728cca5d4974.tar.gz
gnu: et: Don't use unstable tarball.
This follows up commit ae113b976bfb71168a737c6a9a82cd87782077d0 (what
looked like a build error was transient file system unrelatedness.)

* gnu/packages/ssh.scm (et)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index f912ae2cb8..9a80b81849 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -442,12 +442,12 @@ especially over Wi-Fi, cellular, and long-distance links.")
     (version "3.1.0")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append
-             "https://github.com/MisterTea/EternalTCP/archive/et-v"
-             version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/MisterTea/EternalTCP.git")
+             (commit (string-append "et-v" version))))
        (sha256
-        (base32 "0k34l33ns2i2fijvw6ypxjmjcih11ydi9ha84jr8vdx8ii7p8p11"))))
+        (base32 "1m5caxckn2ihwp9s2pbyh5amxlpwr7yc54q8s0kb10fr52w2vfnm"))))
     (build-system cmake-build-system)
     (arguments `(#:tests? #f))
     (native-inputs