summary refs log tree commit diff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-27 11:35:50 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-30 14:58:44 +0100
commit36f26211bbb2c4dffe33427d4e65d5225a586a5b (patch)
tree116cde6e14c3aef0b8bc9c406a0163c851b4c939 /gnu/packages/ssh.scm
parenta9ee11d5ab61d6dd64113d71c5a9c8511c1d050d (diff)
downloadguix-36f26211bbb2c4dffe33427d4e65d5225a586a5b.tar.gz
gnu: openssh: Install ssh-copy-id.
* gnu/packages/ssh.scm (openssh)[arguments]: Install "ssh-copy-id" and
  documentation.

Fixes <http://bugs.gnu.org/22024>.
Reported by Florian Paul Schmidt <mista.tapas@gmx.net>.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 26729ea909..5c222a22ad 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -145,9 +145,19 @@ a server that supports the SSH-2 protocol.")
               (string-append pre post)))
            #t))
         (replace 'install
-         (lambda* (#:key (make-flags '()) #:allow-other-keys)
+         (lambda* (#:key outputs (make-flags '()) #:allow-other-keys)
            ;; install without host keys and system configuration files
-           (zero? (apply system* "make" "install-nosysconf" make-flags)))))))
+           (and (zero? (apply system* "make" "install-nosysconf" make-flags))
+                (begin
+                  (install-file "contrib/ssh-copy-id"
+                                (string-append (assoc-ref outputs "out")
+                                               "/bin/"))
+                  (chmod (string-append (assoc-ref outputs "out")
+                                        "/bin/ssh-copy-id") #o555)
+                  (install-file "contrib/ssh-copy-id.1"
+                                (string-append (assoc-ref outputs "out")
+                                               "/share/man/man1/"))
+                  #t)))))))
    (synopsis "Client and server for the secure shell (ssh) protocol")
    (description
     "The SSH2 protocol implemented in OpenSSH is standardised by the