summary refs log tree commit diff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-30 14:18:35 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-30 17:06:42 +0200
commit61f34ae5bbbb492254a3e618548d7019c3b3898f (patch)
tree73bf74797923ac18f4bd794e8569c8f372975463 /gnu/packages/ssh.scm
parent25280065814aecd7ce56baf4866b0c05acf8028b (diff)
downloadguix-61f34ae5bbbb492254a3e618548d7019c3b3898f.tar.gz
gnu: libssh2: Update to 1.9.0.
* gnu/packages/patches/libssh2-fix-build-failure-with-gcrypt.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
* gnu/packages/ssh.scm (libssh2): Update to 1.9.0.
[source](patches): Remove.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index c04fa6fbfd..596bc55a12 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -111,7 +111,7 @@ applications.")
 (define-public libssh2
   (package
    (name "libssh2")
-   (version "1.8.2")
+   (version "1.9.0")
    (source (origin
             (method url-fetch)
             (uri (string-append
@@ -119,21 +119,13 @@ applications.")
                    version ".tar.gz"))
             (sha256
              (base32
-              "0rqd37pc80nm2pz4sa2m9pfc48axys7jwq1l7z0vii5nyvchg0q8"))
-            (patches
-             (search-patches "libssh2-fix-build-failure-with-gcrypt.patch"))))
+              "1zfsz9nldakfz61d2j70pk29zlmj7w2vv46s9l3x2prhcgaqpyym"))))
    (build-system gnu-build-system)
    ;; The installed libssh2.pc file does not include paths to libgcrypt and
    ;; zlib libraries, so we need to propagate the inputs.
    (propagated-inputs `(("libgcrypt" ,libgcrypt)
                         ("zlib" ,zlib)))
-   (arguments `(#:configure-flags `("--with-libgcrypt")
-                #:phases (modify-phases %standard-phases
-                           (replace 'bootstrap
-                             (lambda _
-                               (invoke "autoreconf" "-v"))))))
-   (native-inputs `(("autoconf" ,autoconf)
-                    ("automake" ,automake)))
+   (arguments `(#:configure-flags `("--with-libgcrypt")))
    (synopsis "Client-side C library implementing the SSH2 protocol")
    (description
     "libssh2 is a library intended to allow software developers access to