summary refs log tree commit diff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-02-16 23:12:04 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-02-17 03:20:16 +0100
commit63b148f70fa1292a4983fcc787792f7ff517b9f4 (patch)
treeeafa5c09d71aad3f93e746a694dcc40b291fbf61 /gnu/packages/ssh.scm
parent8b9cad01e9619f53dc5a65892ca6a09ca5de3447 (diff)
downloadguix-63b148f70fa1292a4983fcc787792f7ff517b9f4.tar.gz
gnu: endlessh: Update to 1.1.
* gnu/packages/ssh.scm (endlessh): Update to 1.1.
[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index d203bb1455..8acc7ce2ed 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -769,23 +769,24 @@ of existing remote shell facilities such as SSH.")
 (define-public endlessh
   (package
     (name "endlessh")
-    (version "1.0")
+    (version "1.1")
     (source
       (origin
-        (method url-fetch)
-        (uri (string-append "https://github.com/skeeto/endlessh/releases/"
-                            "download/" version "/endlessh-" version ".tar.xz"))
+        (method git-fetch)
+        (uri (git-reference
+              (url "https://github.com/skeeto/endlessh.git")
+              (commit version)))
+        (file-name (git-file-name name version))
         (sha256
-         (base32
-          "0hhsr65hzrcb7ylskmxyr92svzndhks8hqzn8hvg7f7j89rkvq5k"))))
+         (base32 "0ziwr8j1frsp3dajr8h5glkm1dn5cci404kazz5w1jfrp0736x68"))))
     (build-system gnu-build-system)
     (arguments
      '(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
                           "CC=gcc")
-       #:tests? #f ; no test target
+       #:tests? #f                      ; no test target
        #:phases
        (modify-phases %standard-phases
-         (delete 'configure)))) ; no configure script
+         (delete 'configure))))         ; no configure script
     (home-page "https://github.com/skeeto/endlessh")
     (synopsis "SSH tarpit that slowly sends an endless banner")
     (description