summary refs log tree commit diff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-07-11 19:48:12 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-07-11 21:07:24 +0200
commitf718c0a05d64ac8f86c83ea099e68944254b1959 (patch)
tree18d4d8561ab4a9b2d5106bd4a6e9fe6142aa3ec4 /gnu/packages/ssh.scm
parent16f6889b74fe9437ce020152cae9c550b77e390f (diff)
downloadguix-f718c0a05d64ac8f86c83ea099e68944254b1959.tar.gz
gnu: hss: Fix cross-compilation.
* gnu/packages/ssh.scm (hss)[arguments]: Move $CC to MAKE-FLAGS and use
CC-FOR-TARGET.  Rename ‘pre-env’ to the more accurate ‘patch-file-names’.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 8d2f1d57b3..330675f8f3 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -87,17 +87,18 @@
     (inputs
      `(("readline" ,readline)))
     (arguments
-     `(#:tests? #f ;no tests
+     `(#:make-flags
+       (list ,(string-append "CC=" (cc-for-target)))
+       #:tests? #f                      ; no tests
        #:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'set-env
+         (add-after 'unpack 'patch-file-names
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (substitute* "Makefile"
                (("/usr/local/bin")
                 (string-append (assoc-ref outputs "out") "/bin"))
                (("/usr/local/opt/readline")
                 (assoc-ref inputs "readline")))
-             (setenv "CC" "gcc")))
          (delete 'configure))))
     (build-system gnu-build-system)
     (home-page "https://github.com/six-ddc/hss/")