summary refs log tree commit diff
path: root/gnu/packages/sssd.scm
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2021-10-03 17:11:11 +0200
committerLudovic Courtès <ludo@gnu.org>2021-10-07 10:47:43 +0200
commit6be0bdf50660d1019d9fe469f139f03f12bf9e21 (patch)
treea40349729d77da32057bff504b066510475116bd /gnu/packages/sssd.scm
parentbe1651990295d3fd66b61f516107625d74d7d68c (diff)
downloadguix-6be0bdf50660d1019d9fe469f139f03f12bf9e21.tar.gz
gnu: Add adcli.
* gnu/packages/sssd.scm (adcli): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/sssd.scm')
-rw-r--r--gnu/packages/sssd.scm62
1 files changed, 62 insertions, 0 deletions
diff --git a/gnu/packages/sssd.scm b/gnu/packages/sssd.scm
index b2b5da96f8..9191440970 100644
--- a/gnu/packages/sssd.scm
+++ b/gnu/packages/sssd.scm
@@ -2,6 +2,7 @@
 ;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2021 Timotej Lazar <timotej.lazar@araneo.si>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -22,12 +23,14 @@
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix utils)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
   #:use-module (gnu packages)
   #:use-module (gnu packages adns)
   #:use-module (gnu packages augeas)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages check)
   #:use-module (gnu packages curl)
   #:use-module (gnu packages cyrus-sasl)
@@ -50,6 +53,65 @@
   #:use-module (gnu packages web)
   #:use-module (gnu packages xml))
 
+(define-public adcli
+  (package
+    (name "adcli")
+    (version "0.9.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.freedesktop.org/realmd/adcli.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1mwzd5vakdsssdvs6vljqpp8pw8i97n5lhxvmn9dn9720am7hfv7"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags
+       ;; The net tool is used to update the stored machine key for samba.
+       (list (string-append "--with-samba-data-tool="
+                            (assoc-ref %build-inputs "samba") "/bin/net"))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'use-local-docbook
+           ;; Patch Makefile and docs to use local docbook resources.
+           (lambda _
+             (let* ((docbook-xml (assoc-ref %build-inputs "docbook-xml"))
+                    (docbook-xsl (assoc-ref %build-inputs "docbook-xsl"))
+                    (xsldir (string-append docbook-xsl "/xml/xsl/docbook-xsl-"
+                                           ,(package-version docbook-xsl))))
+                    (with-directory-excursion "doc"
+                      (substitute*
+                          '("Makefile.am" "adcli.xml" "adcli-devel.xml" "adcli-docs.xml")
+                        (("http://docbook.sourceforge.net/release/xsl/current(/[^\"]*)" _ path)
+                         (string-append xsldir path))
+                        (("http://www.oasis-open.org/docbook/xml/4.3/docbookx.dtd")
+                         (string-append docbook-xml "/xml/dtd/docbook/docbookx.dtd")))
+                      (substitute* "Makefile.am"
+                        (("\\$\\(XMLTO\\)" xmlto)
+                         (string-append xmlto " --searchpath " xsldir "/html"))))))))))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("docbook-xml" ,docbook-xml)
+       ("docbook-xsl" ,docbook-xsl)
+       ("libtool" ,libtool)
+       ("libxslt" ,libxslt)
+       ("util-linux" ,util-linux) ; For `rev` command used in tests.
+       ("xmlto" ,xmlto)))
+    (inputs
+     `(("cyrus-sasl" ,cyrus-sasl)
+       ("mit-krb5" ,mit-krb5)
+       ("samba" ,samba)
+       ("openldap" ,openldap)))
+    (home-page "https://gitlab.freedesktop.org/realmd/adcli/")
+    (synopsis "Helper library and tools for Active Directory client operations")
+    (description "@command{adcli} is a command‐line tool to join a computer to
+an Active Directory domain.  It can also update the machine password and
+manage user, group and computer accounts for a domain.")
+    (license license:lgpl2.1+)))
+
 (define-public ding-libs
   (package
     (name "ding-libs")