summary refs log tree commit diff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-08 21:12:52 +0200
committerMarius Bakke <marius@gnu.org>2022-09-08 21:12:52 +0200
commit884548b476f2ee27c01cb0c9ad93c0cf9d33fa5e (patch)
tree20650b3917b1292470ecc4ded13fbb04e5dbfa6d /gnu/packages/statistics.scm
parent0e305798454c558ab6e722cf66ba351c326a1a8d (diff)
parentfa894b3f4db835bd0bb52b32c7ec412e72b7e03a (diff)
downloadguix-884548b476f2ee27c01cb0c9ad93c0cf9d33fa5e.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 5ab2c5e764..4b6328a587 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -7129,3 +7129,48 @@ otting the results.")
        "This package provides a collection of (mostly simple) functions for
 generating and manipulating colors in R.")
       (license license:gpl3))))
+
+(define-public r-reghelper
+  (package
+    (name "r-reghelper")
+    (version "1.1.1")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "reghelper" version))
+              (sha256
+               (base32
+                "0v1987rs6kcpizfhrp3hxsyx9arn5vsbapjfgj9478j73mm844ji"))))
+    (properties `((upstream-name . "reghelper")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-ggplot2 r-lme4 r-mass r-nlme))
+    (home-page "https://github.com/jeff-hughes/reghelper")
+    (synopsis "Helper Functions for Regression Analysis")
+    (description
+     "This package provides a set of functions used to automate commonly used methods
+in regression analysis.  This includes plotting interactions, and calculating
+simple slopes, standardized coefficients, regions of significance (Johnson &
+Neyman, 1936; cf.  Spiller et al., 2012), etc.")
+    (license license:gpl3)))
+
+(define-public r-mumin
+  (package
+    (name "r-mumin")
+    (version "1.47.1")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "MuMIn" version))
+              (sha256
+               (base32
+                "1xhsc9hmx2b3zqyvpjs64rs90ccrfcsglrq2mhh85mgplsnva8qj"))))
+    (properties `((upstream-name . "MuMIn")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-matrix r-nlme))
+    (home-page "https://cran.r-project.org/package=MuMIn")
+    (synopsis "Multi-Model Inference")
+    (description
+     "Tools for performing model selection and model averaging.  Automated model
+selection through subsetting the maximum model, with optional constraints for
+model inclusion.  Model parameter and prediction averaging based on model
+weights derived from information criteria (AICc and alike) or custom model
+weighting schemes.")
+    (license license:gpl2)))