summary refs log tree commit diff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-05-27 01:26:09 -0400
committerMark H Weaver <mhw@netris.org>2018-05-27 01:26:09 -0400
commit1640f16e7888291227d11647dbb5f83ad5d138a1 (patch)
treebf979aa4e6538b8261762cfbb80512ebb023b016 /gnu/packages/statistics.scm
parent0ff4e49a95d8a54cd5508f441b927a670d348519 (diff)
parenta4e45acdc07fc3faf2844b3658ee31ebc538bd1c (diff)
downloadguix-1640f16e7888291227d11647dbb5f83ad5d138a1.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 9039c1204c..d95b041843 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -61,6 +61,7 @@
   #:use-module (gnu packages python)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages ssh)
+  #:use-module (gnu packages tcl)
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages time)
   #:use-module (gnu packages tls)
@@ -216,7 +217,7 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
          (add-after 'build 'install-info
           (lambda _ (zero? (system* "make" "install-info")))))
        #:configure-flags
-       '(;; Do not build the recommended packages.  The build system creates
+       `(;; Do not build the recommended packages.  The build system creates
          ;; random temporary directories and embeds their names in some
          ;; package files.  We build these packages with the r-build-system
          ;; instead.
@@ -227,6 +228,13 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
          "--with-jpeglib"
          "--with-libtiff"
          "--with-ICU"
+         "--with-tcltk"
+         ,(string-append "--with-tcl-config="
+                         (assoc-ref %build-inputs "tcl")
+                         "/lib/tclConfig.sh")
+         ,(string-append "--with-tk-config="
+                         (assoc-ref %build-inputs "tk")
+                         "/lib/tkConfig.sh")
          "--enable-R-shlib"
          "--enable-BLAS-shlib"
          "--with-system-tre")))
@@ -265,6 +273,8 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
        ;; This avoids a reference to the ungraftable static bash.  R uses the
        ;; detected shell for the "system" procedure.
        ("bash" ,bash-minimal)
+       ("tcl" ,tcl)
+       ("tk" ,tk)
        ("which" ,which)
        ("zlib" ,zlib)))
     (native-search-paths