summary refs log tree commit diff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-07 15:41:18 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-07 15:55:06 +0100
commit61f2587db98284ec555c2b3899ff6998f9bd91d3 (patch)
tree5981ce83a929bd0cce27b0a9dabbad1f3bcb1293 /gnu/packages/statistics.scm
parente0d3f4bf1a8306194ebd140b4bea62629ee351f7 (diff)
downloadguix-61f2587db98284ec555c2b3899ff6998f9bd91d3.tar.gz
gnu: python-rpy2: Move to (gnu packages statistics).
* gnu/packages/python.scm (python-rpy2): Move from here...
* gnu/packages/statistics.scm (python-rpy2): ...to here.
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm58
1 files changed, 58 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index cc879be99c..1e28b9234b 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -5711,6 +5711,64 @@ plotting function (and equivalents of curve, density, acf and barplot) as well
 as a boxplot function.")
     (license license:lgpl3+)))
 
+(define-public python-rpy2
+  (package
+    (name "python-rpy2")
+    (version "2.9.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "rpy2" version))
+       (sha256
+        (base32
+         "0bl1d2qhavmlrvalir9hmkjh74w21vzkvc2sg3cbb162s10zfmxy"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:modules ((ice-9 ftw)
+                  (srfi srfi-1)
+                  (srfi srfi-26)
+                  (guix build utils)
+                  (guix build python-build-system))
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key outputs inputs #:allow-other-keys)
+             (let ((cwd (getcwd)))
+               (setenv "PYTHONPATH"
+                       (string-append cwd "/build/"
+                                      (find (cut string-prefix? "lib" <>)
+                                            (scandir (string-append cwd "/build")))
+                                      ":"
+                                      (getenv "PYTHONPATH"))))
+             (invoke "python" "-m" "rpy2.tests" "-v"))))))
+    (propagated-inputs
+     `(("python-six" ,python-six)
+       ("python-jinja2" ,python-jinja2)
+       ("python-pytz" ,python-pytz)))
+    (inputs
+     `(("readline" ,readline)
+       ("icu4c" ,icu4c)
+       ("pcre" ,pcre)
+       ("r-minimal" ,r-minimal)
+       ("r-survival" ,r-survival)
+       ("r-ggplot2" ,r-ggplot2)
+       ("r-rsqlite" ,r-rsqlite)
+       ("r-dplyr" ,r-dplyr)
+       ("r-dbplyr" ,r-dbplyr)
+       ("python-numpy" ,python-numpy)))
+    (native-inputs
+     `(("zlib" ,zlib)))
+    (home-page "https://rpy2.bitbucket.io/")
+    (synopsis "Python interface to the R language")
+    (description "rpy2 is a redesign and rewrite of rpy.  It is providing a
+low-level interface to R from Python, a proposed high-level interface,
+including wrappers to graphical libraries, as well as R-like structures and
+functions.")
+    ;; Any of these licenses can be picked for the R interface.  The whole
+    ;; project is released under GPLv2+ according to the license declaration
+    ;; in "setup.py".
+    (license (list license:mpl2.0 license:gpl2+ license:lgpl2.1+))))
+
 (define-public java-jdistlib
   (package
     (name "java-jdistlib")