summary refs log tree commit diff
path: root/gnu/packages/stb.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-14 20:46:49 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-15 00:12:12 +0100
commit0e8df7403e0e340456b5420645a96da2cd343c99 (patch)
tree8f5b5f0e1c62e379b8ede0dda369b3617da5b9e7 /gnu/packages/stb.scm
parent6f5f60b2891b15036375be28ace1ca87e250d667 (diff)
downloadguix-0e8df7403e0e340456b5420645a96da2cd343c99.tar.gz
gnu: Update stb to b42009b3b9d4ca35bc703f5310eedc74f584be58.
* gnu/packages/stb.scm (stb): Update to commit b42009b3b9d4ca35bc703f5310eedc74f584be58..
(stb-image): Update version number to 2.26.
(stb-image-write): Update version number to 1.15.
(stb-sprintf): Update version number to 1.09.
(stb-truetype): Update version number to 1.24.
Diffstat (limited to 'gnu/packages/stb.scm')
-rw-r--r--gnu/packages/stb.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/stb.scm b/gnu/packages/stb.scm
index d58b180c69..094ece536d 100644
--- a/gnu/packages/stb.scm
+++ b/gnu/packages/stb.scm
@@ -27,8 +27,8 @@
 (define stb
   ;; stb is a collection of libraries developed within the same repository.
   ;; When updating this, remember to change versions below as appropriate.
-  (let ((commit "2c2908f50515dcd939f24be261c3ccbcd277bb49")
-        (revision "1"))
+  (let ((commit "b42009b3b9d4ca35bc703f5310eedc74f584be58")
+        (revision "2"))
     (package
       (name "stb")
       (home-page "https://github.com/nothings/stb")
@@ -40,7 +40,7 @@
                       (commit commit)))
                 (sha256
                  (base32
-                  "1z753rscqc4clp0rd57bw68i60kz694y1z52bwv6slzmkgds1cki"))
+                  "1gmcjhmj62mfdscrsg2hv4j4j9v447y8zj3rbrm7mqn94cx73z1i"))
                 (file-name (git-file-name name version))))
       (build-system gnu-build-system)
       (arguments
@@ -93,13 +93,13 @@ the C programming language.")
 ;; converted to macros as outlined in <https://bugs.gnu.org/32155>.
 (define-public stb-image
   (make-stb-header-package
-   "stb-image" "2.22"
+   "stb-image" "2.26"
    "stb-image is a small and self-contained library for image loading or
 decoding from file or memory.  A variety of formats are supported."))
 
 (define-public stb-image-write
   (make-stb-header-package
-   "stb-image-write" "1.13"
+   "stb-image-write" "1.15"
    "stb-image-write is a small library for writing image files to the
 C@tie{}@code{stdio} interface."))
 
@@ -111,11 +111,11 @@ rectangular textures into an atlas.  It does not do rotation."))
 
 (define-public stb-sprintf
   (make-stb-header-package
-   "stb-sprintf" "1.06"
+   "stb-sprintf" "1.09"
    "stb-sprintf implements fast @code{sprintf}, @code{snprintf} for C/C++."))
 
 (define-public stb-truetype
   (make-stb-header-package
-   "stb-truetype" "1.22"
+   "stb-truetype" "1.24"
    "stb-truetype is a library for parsing, decoding, and rasterizing
 characters from TrueType fonts."))