summary refs log tree commit diff
path: root/gnu/packages/stb.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-14 20:40:46 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-15 00:12:11 +0100
commit6f5f60b2891b15036375be28ace1ca87e250d667 (patch)
tree1d1da4592ac31b9d9c0a9062af630cb800ef49d0 /gnu/packages/stb.scm
parent89f25a813a7aae348fdb186d215ead6e044af8fc (diff)
downloadguix-6f5f60b2891b15036375be28ace1ca87e250d667.tar.gz
gnu: Add stb-rect-pack.
* gnu/packages/stb.scm (stb-rect-pack): New public variable.
Diffstat (limited to 'gnu/packages/stb.scm')
-rw-r--r--gnu/packages/stb.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/stb.scm b/gnu/packages/stb.scm
index 9cb2ae10b6..d58b180c69 100644
--- a/gnu/packages/stb.scm
+++ b/gnu/packages/stb.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -102,6 +103,12 @@ decoding from file or memory.  A variety of formats are supported."))
    "stb-image-write is a small library for writing image files to the
 C@tie{}@code{stdio} interface."))
 
+(define-public stb-rect-pack
+  (make-stb-header-package
+   "stb-rect-pack" "1.00"
+   "stb-rect-pack is a small rectangle packing library useful for, e.g., packing
+rectangular textures into an atlas.  It does not do rotation."))
+
 (define-public stb-sprintf
   (make-stb-header-package
    "stb-sprintf" "1.06"