summary refs log tree commit diff
path: root/gnu/packages/storage.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-23 23:16:55 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-23 23:16:55 +0100
commit8c14f7f8a7ab0722bf4c9f92fd28ae85514d564f (patch)
treeadc5d29e9c2dcda5befa0ca81f1af8df23294947 /gnu/packages/storage.scm
parent2f33a7321e5e37d37f57c229c8079cb4ffd10834 (diff)
parent3374e9207f5244c20402a3c5513fe562140fef47 (diff)
downloadguix-8c14f7f8a7ab0722bf4c9f92fd28ae85514d564f.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/storage.scm')
-rw-r--r--gnu/packages/storage.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/storage.scm b/gnu/packages/storage.scm
index 4cff9665d5..0c25e03ffc 100644
--- a/gnu/packages/storage.scm
+++ b/gnu/packages/storage.scm
@@ -54,14 +54,14 @@
 (define-public ceph
   (package
     (name "ceph")
-    (version "13.2.2")
+    (version "13.2.5")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://download.ceph.com/tarballs/ceph-"
                                   version ".tar.gz"))
               (sha256
                (base32
-                "0h483n9iy0fkbqrhf7k0dzspwdpcaswkjwmc5n5c600fr6s1v9pk"))
+                "0jbs6l763clbqnq2s5jksn44yf71rhcnk85cw64fqvmv0r4ch71n"))
               (patches
                (search-patches "ceph-skip-unittest_blockdev.patch"
                                "ceph-skip-collect-sys-info-test.patch"
@@ -93,6 +93,8 @@
               (libdir (string-append lib "/lib")))
          (list (string-append "-DCMAKE_INSTALL_PREFIX=" out)
                (string-append "-DCMAKE_INSTALL_LIBDIR=" libdir)
+               (string-append "-DCMAKE_INSTALL_INCLUDEDIR="
+                              lib "/include")
                ;; We need both libdir and libdir/ceph in RUNPATH.
                (string-append "-DCMAKE_INSTALL_RPATH="
                               libdir ";" libdir "/ceph")
@@ -102,6 +104,8 @@
                (string-append "-DCMAKE_INSTALL_LIBEXECDIR=" out "/libexec")
                (string-append "-DKEYUTILS_INCLUDE_DIR="
                               (assoc-ref %build-inputs "keyutils") "/include")
+               (string-append "-DXFS_INCLUDE_DIR="
+                              (assoc-ref %build-inputs "xfsprogs") "/include")
                "-DCMAKE_INSTALL_LOCALSTATEDIR=/var"
                "-DENABLE_SHARED=ON"
                "-DWITH_SYSTEM_ROCKSDB=ON"
@@ -112,7 +116,6 @@
                "-DWITH_BABELTRACE=OFF"
                "-DWITH_LTTNG=OFF"
                "-DWITH_SPDK=OFF"
-               "-DWITH_XFS=OFF"
                "-DWITH_XIO=OFF"
                ;; Use jemalloc instead of tcmalloc.
                "-DALLOCATOR=jemalloc"))
@@ -127,11 +130,6 @@
              (let ((out (assoc-ref outputs "out"))
                    (lib (assoc-ref outputs "lib")))
 
-               ;; Make header files follow the dynamic libraries.
-               (substitute* "src/include/CMakeLists.txt"
-                 (("DESTINATION include")
-                  (string-append "DESTINATION " lib "/include")))
-
                (substitute* "cmake/modules/Distutils.cmake"
                  ;; Prevent creation of Python eggs.
                  (("setup.py install")
@@ -344,6 +342,7 @@
        ("snappy" ,snappy)
        ("udev" ,eudev)
        ("util-linux" ,util-linux)
+       ("xfsprogs" ,xfsprogs)
        ("zlib" ,zlib)))
     (home-page "https://ceph.com/")
     (synopsis "Distributed object store and file system")