summary refs log tree commit diff
path: root/gnu/packages/storage.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-06-30 19:00:36 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-06-30 19:02:46 +0200
commita583d01a8a0571970df6c4506b611a3483535454 (patch)
tree1748ba96c5695495ee6c097871e46cb221dfc253 /gnu/packages/storage.scm
parentc0164344b869247fa84a2c1417d9af09a0fd1292 (diff)
downloadguix-a583d01a8a0571970df6c4506b611a3483535454.tar.gz
gnu: ceph: Update to 14.2.10 [fixes CVE-2020-10753].
* gnu/packages/storage.scm (ceph): Update to 14.2.10.
[source]: Keep required bundled seastar.
[inputs]: Add librdkafka.
Diffstat (limited to 'gnu/packages/storage.scm')
-rw-r--r--gnu/packages/storage.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/storage.scm b/gnu/packages/storage.scm
index 481ffade5c..b7d4056635 100644
--- a/gnu/packages/storage.scm
+++ b/gnu/packages/storage.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2017, 2018, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -40,6 +41,7 @@
   #:use-module (gnu packages linux)
   #:use-module (gnu packages lua)
   #:use-module (gnu packages ncurses)
+  #:use-module (gnu packages networking)
   #:use-module (gnu packages nss)
   #:use-module (gnu packages openldap)
   #:use-module (gnu packages pkg-config)
@@ -53,14 +55,14 @@
 (define-public ceph
   (package
     (name "ceph")
-    (version "14.2.9")
+    (version "14.2.10")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://download.ceph.com/tarballs/ceph-"
                                   version ".tar.gz"))
               (sha256
                (base32
-                "0zkh1a23v8g1fa5flqa2d53lv08ancab3li57gybpqpnja90k7il"))
+                "0bbs3ag8zav283qpxrrndhvh2z01ykm6126fmwrbc1c5f9jfjq39"))
               (patches
                (search-patches "ceph-disable-cpu-optimizations.patch"))
               (modules '((guix build utils)))
@@ -73,7 +75,7 @@
                               ;"src/xxHash"
                               ;"src/zstd"
                               ;"src/civetweb"
-                              "src/seastar/fmt"
+                              ;"src/seastar/fmt"
                               "src/test/downloads"
                               "src/c-ares"
                               "src/googletest"
@@ -213,6 +215,7 @@
        ("libatomic-ops" ,libatomic-ops)
        ("libcap-ng" ,libcap-ng)
        ("libnl" ,libnl)
+       ("librdkafka" ,librdkafka)
        ("lua" ,lua)
        ("lz4" ,lz4)
        ("oath-toolkit" ,oath-toolkit)