summary refs log tree commit diff
path: root/gnu/packages/sync.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-02-20 09:05:30 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-02-20 09:06:40 +0200
commit2b371f4dd5ddafa0786240b40408ef5c30d7a526 (patch)
treee0a87ffceb239ec848a29ab777cc84446b75fdcf /gnu/packages/sync.scm
parentc6d8817ec4f7ef7333d7bf7c9db93e4085cf43e9 (diff)
downloadguix-2b371f4dd5ddafa0786240b40408ef5c30d7a526.tar.gz
gnu: Don't use the store path in the .desktop file.
This fixes bug#30228.

* gnu/packages/sync.scm (owncloud-client)[arguments]: Add a custom phase
to substitute the executable name for the full path to the binary.
Remove the 'patch-dot-desktop-files phase.
Diffstat (limited to 'gnu/packages/sync.scm')
-rw-r--r--gnu/packages/sync.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index df9f3b0e16..450e7b767a 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -79,7 +79,13 @@
              (substitute* "test/CMakeLists.txt"
                           (("owncloud_add_test\\(Utility \"\"\\)" test)
                            (string-append "#" test)))
-             #t)))
+             #t))
+         (add-after 'unpack 'dont-embed-store-path
+           (lambda _
+             (substitute* "src/common/utility_unix.cpp"
+               (("QCoreApplication::applicationFilePath\\()") "\"owncloud\""))
+             #t))
+         (delete 'patch-dot-desktop-files))
        #:configure-flags '("-DUNIT_TESTING=ON"
                            ;; build without qtwebkit, which causes the
                            ;; package to FTBFS while looking for QWebView.