summary refs log tree commit diff
path: root/gnu/packages/sync.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-11-18 19:30:22 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-11-18 21:50:08 +0200
commit6563d58c7e94bee8b9beeefa929ab2e982d86fa0 (patch)
treea739db58d6a9ac9e2f3e0373dea8d15d2bbdb91a /gnu/packages/sync.scm
parent42ca84be9260d6a1ce12847b89545882b112a2cd (diff)
downloadguix-6563d58c7e94bee8b9beeefa929ab2e982d86fa0.tar.gz
gnu: owncloud-client: Don't check for updates.
* gnu/packages/sync.scm (owncloud-client)[source]: Add patch.
* gnu/packages/patches/owncloud-disable-updatecheck.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/sync.scm')
-rw-r--r--gnu/packages/sync.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index 66e9c4eddb..17972cd4ad 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -22,6 +22,7 @@
   #:use-module (guix build-system cmake)
   #:use-module (guix download)
   #:use-module (guix packages)
+  #:use-module (gnu packages)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages databases)
@@ -43,6 +44,7 @@
                            "owncloudclient-" version ".tar.xz"))
        (sha256
         (base32 "1r5ddln1wc9iyjizgqb104i0r6qhzsmm2wdnxfaif119cv0vphda"))
+       (patches (search-patches "owncloud-disable-updatecheck.patch"))
        (modules '((guix build utils)))
        (snippet
         '(begin