summary refs log tree commit diff
path: root/gnu/packages/sync.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-01-25 14:20:53 -0500
committerLeo Famulari <leo@famulari.name>2022-02-09 11:57:20 -0500
commit4578ad78bee1dfd450962627ae66d3e15ebadad2 (patch)
treee2b625b99389698b27df1a617289231267dab421 /gnu/packages/sync.scm
parentf05f831f66b957c7f1e651763dcbbb98c2d76266 (diff)
downloadguix-4578ad78bee1dfd450962627ae66d3e15ebadad2.tar.gz
gnu: QSyncthingTray: Deprecate in favor of Debian's syncthing-gtk fork.
This package is abandoned upstream and depends on the insecure and
abandoned QtWebKit.

Upstream abandonment:

https://github.com/sieren/QSyncthingTray/issues/247

See <https://issues.guix.gnu.org/53289> for more information about this change

* gnu/packages/sync.scm (qsyncthingtray): Move this variable ...
* gnu/packages/syncthing.scm (qsyncthingtray): ... to here. And make it into a
deprecated-package that points to syncthing-gtk.
Diffstat (limited to 'gnu/packages/sync.scm')
-rw-r--r--gnu/packages/sync.scm52
1 files changed, 0 insertions, 52 deletions
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index f897c1ec4a..801aef3f44 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -359,58 +359,6 @@ synchronize to the same server and any change to the files on one computer will
 silently and reliably flow across to every other.")
     (license license:gpl2+)))
 
-(define-public qsyncthingtray
-  (package
-    (name "qsyncthingtray")
-    (version "0.5.8")
-    (source
-      (origin
-        (method git-fetch)
-        (uri (git-reference
-               (url "https://github.com/sieren/QSyncthingTray")
-               (commit version)))
-        (file-name (git-file-name name version))
-        (sha256
-         (base32
-          "1n9g4j7qznvg9zl6x163pi9f7wsc3x6q76i33psnm7x2v1i22x5w"))))
-    (build-system cmake-build-system)
-    (arguments
-     `(#:configure-flags '("-DQST_BUILD_WEBKIT=1")
-       #:phases
-       (modify-phases %standard-phases
-         ;; The program is meant to be run from the git repo or source tarball.
-         (replace 'install
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (bin (string-append out "/bin")))
-               (install-file "QSyncthingTray" bin)
-               (mkdir-p (string-append out "/share/pixmaps"))
-               (copy-file "../source/resources/images/Icon1024.png"
-                          (string-append
-                            out "/share/pixmaps/QSyncthingTray.png"))
-               #t))))
-       #:tests? #f)) ; no test target
-    (inputs
-     (list qtbase-5 qtwebkit))
-    (home-page "https://github.com/sieren/QSyncthingTray")
-    (synopsis "Traybar Application for Syncthing")
-    (description
-     "A traybar application for syncthing.
-@enumerate
-@item Shows number of connections at a glance.
-@item Traffic statistics about incoming, outgoing and total throughput.
-@item Launches Syncthing and Syncthing-iNotifier if specified.
-@item Quickly pause Syncthing with one click.
-@item Last Synced Files - Quickly see the recently synchronised files and open
-their folder.
-@item Quick Access to all shared folders.
-@item Presents Syncthing UI in a separate view instead of using the browser.
-@item Supports authenticated HTTPS connections.
-@item Uses System Notifications about current connection status.
-@item Toggle for monochrome icon.
-@end enumerate\n")
-    (license license:lgpl3+)))
-
 (define-public lsyncd
   (package
     (name "lsyncd")