summary refs log tree commit diff
path: root/gnu/packages/sync.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-01-02 18:25:41 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-01-02 19:53:06 +0200
commitafbf9763faf231c27ef25315d4d24379e1762568 (patch)
tree60edd7169681b8b5dbd47606174a4de93ccba0ac /gnu/packages/sync.scm
parenta69f071537ce5dfd3419054dc85a598d0b702864 (diff)
downloadguix-afbf9763faf231c27ef25315d4d24379e1762568.tar.gz
gnu: qtsyncthingtray: Use 'git-fetch'.
* gnu/packages/sync.scm (qtsyncthingtray)[source]: Use 'git-fetch'.
[arguments]: Update custom 'install phase.
Diffstat (limited to 'gnu/packages/sync.scm')
-rw-r--r--gnu/packages/sync.scm22
1 files changed, 10 insertions, 12 deletions
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index 596ef4b5c0..a1d4230d98 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -109,14 +109,14 @@ silently and reliably flow across to every other.")
     (version "0.5.8")
     (source
       (origin
-        (method url-fetch)
-        (uri (string-append
-               "https://github.com/sieren/QSyncthingTray/archive/"
-               version ".tar.gz"))
-        (file-name (string-append name "-" version ".tar.gz"))
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/sieren/QSyncthingTray")
+               (commit version)))
+        (file-name (git-file-name name version))
         (sha256
          (base32
-          "1024778ml7q62ziqm4d22z5sc1715l34846pwfyzfpcyl32qlhpz"))))
+          "1n9g4j7qznvg9zl6x163pi9f7wsc3x6q76i33psnm7x2v1i22x5w"))))
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags '("-DQST_BUILD_WEBKIT=1")
@@ -128,12 +128,10 @@ silently and reliably flow across to every other.")
              (let* ((out (assoc-ref outputs "out"))
                     (bin (string-append out "/bin")))
                (install-file "QSyncthingTray" bin)
-               (install-file (string-append
-                               "../QSyncthingTray-"
-                               ,(package-version qsyncthingtray)
-                               "/resources/images/Icon1024.png")
-                             (string-append
-                               out "/share/pixmaps/QSyncthingTray.png"))
+               (mkdir-p (string-append out "/share/pixmaps"))
+               (copy-file "../source/resources/images/Icon1024.png"
+                          (string-append
+                            out "/share/pixmaps/QSyncthingTray.png"))
                #t))))
        #:tests? #f)) ; no test target
     (inputs