summary refs log tree commit diff
path: root/gnu/packages/sync.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-11-27 23:57:52 -0500
committerMark H Weaver <mhw@netris.org>2018-11-27 23:58:13 -0500
commite5ace9dd78e455543792671c76c8d78b81f1216c (patch)
tree6751606a3c6dddb4d3f07442d57af946ab97ac2e /gnu/packages/sync.scm
parentf04a5391690c69c3721117c082f682f83c550015 (diff)
downloadguix-e5ace9dd78e455543792671c76c8d78b81f1216c.tar.gz
Revert "gnu: Add rclone."
This reverts commit 8b5e2e94afdef6430583c3a0ef02fe2d7fcc16d1.
Diffstat (limited to 'gnu/packages/sync.scm')
-rw-r--r--gnu/packages/sync.scm44
1 files changed, 0 insertions, 44 deletions
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index 22262db2d6..e0b0af3d96 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -3,7 +3,6 @@
 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -23,7 +22,6 @@
 (define-module (gnu packages sync)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix build-system cmake)
-  #:use-module (guix build-system go)
   #:use-module (guix build-system meson)
   #:use-module (guix download)
   #:use-module (guix git-download)
@@ -245,45 +243,3 @@ over the Internet in an HTTP and CDN friendly way;
 @item An efficient backup system.
 @end itemize\n")
     (license license:lgpl2.1+)))
-
-(define-public rclone
-  (package
-    (name "rclone")
-    (version "1.45")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/ncw/rclone.git")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "06xg0ibv9pnrnmabh1kblvxx1pk8h5rmkr9mjbymv497sx3zgz26"))))
-    (build-system go-build-system)
-    (arguments
-     '(#:import-path "github.com/ncw/rclone"
-       #:install-source? #f
-       (modify-phases %standard-phases
-         ;; Fix failure during "check" phase: "/homeless-shelter: permission
-         ;; denied".
-         (add-after 'unpack 'set-home-directory
-           (lambda _ (setenv "HOME" "/tmp") #t)))))
-    (synopsis "@code{rsync} for cloud storage")
-    (description "@code{Rclone} is a command line program to sync files and
-directories to and from different cloud storage providers.
-
-Features include:
-@itemize
-@item MD5/SHA1 hashes checked at all times for file integrity
-@item Timestamps preserved on files
-@item Partial syncs supported on a whole file basis
-@item Copy mode to just copy new/changed files
-@item Sync (one way) mode to make a directory identical
-@item Check mode to check for file hash equality
-@item Can sync to and from network, e.g., two different cloud accounts
-@item Optional encryption (Crypt)
-@item Optional cache (Cache)
-@item Optional FUSE mount (rclone mount)
-@end itemize")
-    (home-page "https://rclone.org/")
-    (license license:expat)))