summary refs log tree commit diff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-14 11:48:46 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-14 12:05:51 +0100
commit191e5674d9f1b2035f681a939c266efe2dd4a2dd (patch)
treebd23eb0d83c702c8f5458ec15d67621772b55d03 /gnu/packages/syncthing.scm
parent1cfaa79e6d90eb3eaa476a15abc2c4ca8ee78e03 (diff)
downloadguix-191e5674d9f1b2035f681a939c266efe2dd4a2dd.tar.gz
gnu: go-github-com-golang-groupcache: Move to golang-web.
* gnu/packages/syncthing.scm (go-github-com-golang-groupcache): Move
from here ...
* gnu/packages/golang-web.scm: ... to here.

Change-Id: I3e5393d13630529a0cf309e08b9e7dc9d5cba18a
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 0914d618f5..366a5f0ebb 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -353,34 +353,6 @@ structs in the Go programming language.")
     (home-page "https://github.com/d4l3k/messagediff")
     (license expat)))
 
-(define-public go-github-com-golang-groupcache
-  (let ((commit "869f871628b6baa9cfbc11732cdf6546b17c1298")
-        (revision "2"))
-    (package
-      (name "go-github-com-golang-groupcache")
-      (version (git-version "0.0.0" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/golang/groupcache")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "0r4nk8129bvx50qb4xzjaay39b2h6k7cbdqqzdlanmc82ygczsbw"))))
-      (build-system go-build-system)
-      (arguments
-       `(#:import-path "github.com/golang/groupcache"))
-      (propagated-inputs
-       (list go-github-com-golang-protobuf-proto))
-      (synopsis "Groupcache is a caching and cache-filling library")
-      (description "Groupcache is a caching and cache-filling library, intended
-as a replacement for memcached in many cases.  It provides a data loading
-mechanism with caching and de-duplication that works across a set of peer
-processes.")
-      (home-page "https://github.com/golang/groupcache")
-      (license asl2.0))))
-
 (define-public go-github-com-jackpal-gateway
   (package
     (name "go-github-com-jackpal-gateway")