summary refs log tree commit diff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-26 21:25:03 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 00:34:27 +0100
commitf046e348e18939d3a891d5e183f83b3e75df2251 (patch)
treeb6cc5c630cdcf8b96152e2f6d04fc35a30d27167 /gnu/packages/syncthing.scm
parent9fb7946a232919844a600a3633a8944043085d3d (diff)
downloadguix-f046e348e18939d3a891d5e183f83b3e75df2251.tar.gz
gnu: go-github-com-sasha-s-go-deadlock: Move to golang-check.
* gnu/packages/syncthing.scm (go-github-com-sasha-s-go-deadlock): Move
from here ...
* gnu/packages/golang-check.scm: ... to here.

Change-Id: Id3d101897b4ac056cfe48a52289dd3e4f51402d8
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm24
1 files changed, 0 insertions, 24 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 5e7e8f96db..de018065d2 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -403,30 +403,6 @@ higher-level API for doing so.")
     (home-page "https://github.com/oschwald/maxminddb-golang")
     (license isc)))
 
-(define-public go-github-com-sasha-s-go-deadlock
-  (package
-    (name "go-github-com-sasha-s-go-deadlock")
-    (version "0.2.0")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/sasha-s/go-deadlock")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "13p7b7pakd9k1c2k0fs1hfim3c8mivz679977ai6zb01s4aw7gyg"))))
-    (build-system go-build-system)
-    (arguments
-     `(#:import-path "github.com/sasha-s/go-deadlock"))
-    (propagated-inputs
-     (list go-github-com-petermattis-goid))
-    (synopsis "Deadlock detection in go")
-    (description "This package provides tools for detecting deadlocks at
-run-time in Go.")
-    (home-page "https://github.com/sasha-s/go-deadlock")
-    (license asl2.0)))
-
 (define-public go-github-com-thejerf-suture
   (package
     (name "go-github-com-thejerf-suture")