summary refs log tree commit diff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 14:23:53 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 15:28:25 +0100
commitfe2a300eaa09b73dd14d3adf9e4bc4f668892f41 (patch)
tree80a15a19b911deabfca043c4800248682debade6 /gnu/packages/syncthing.scm
parent69f9a43c876390996ead2d5bb83d2106d0cacac2 (diff)
downloadguix-fe2a300eaa09b73dd14d3adf9e4bc4f668892f41.tar.gz
gnu: go-github-com-oschwald-maxminddb-golang: Move to golang-web.
* gnu/packages/syncthing.scm (go-github-com-oschwald-maxminddb-golang):
Move from here ...
* gnu/packages/golang-web.scm: ... to here.

Change-Id: I88e887ccaeecb5c165bff920515dbdef9f8b85ad
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm26
1 files changed, 0 insertions, 26 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 021d66662a..28c3f0dbd2 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -305,32 +305,6 @@ GeoLite2 and GeoIP2 databases in Go.")
     (home-page "https://github.com/oschwald/geoip2-golang")
     (license isc)))
 
-(define-public go-github-com-oschwald-maxminddb-golang
-  (package
-    (name "go-github-com-oschwald-maxminddb-golang")
-    (version "1.4.0")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/oschwald/maxminddb-golang")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "100wd5qv00pkcm6cb8c4x5gavc9jnn7drh6xrqh85hzci4rils66"))))
-    (build-system go-build-system)
-    (propagated-inputs
-     (list go-golang-org-x-sys))
-    (arguments
-     `(#:import-path "github.com/oschwald/maxminddb-golang"
-       #:tests? #f)) ; Requires some unpackaged software and test data
-    (synopsis "MaxMind DB Reader for Go")
-    (description "This is a Go reader for the MaxMind DB format.  Although
-this can be used to read GeoLite2 and GeoIP2 databases, @code{geoip2} provides a
-higher-level API for doing so.")
-    (home-page "https://github.com/oschwald/maxminddb-golang")
-    (license isc)))
-
 (define-public go-github-com-thejerf-suture
   (package
     (name "go-github-com-thejerf-suture")