summary refs log tree commit diff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-01-28 19:25:49 -0500
committerLeo Famulari <leo@famulari.name>2018-02-08 15:18:19 -0500
commit339e44dac20ee24a706878093a5756f0eec4c95f (patch)
treed29b3a5a1e5e6e3cca20243e69e69de1329ed819 /gnu/packages/syncthing.scm
parentd095620a590a8e513bc3c08dff5bb0c1797ddc98 (diff)
downloadguix-339e44dac20ee24a706878093a5756f0eec4c95f.tar.gz
gnu Add go-github-com-golang-protobuf-proto.
* gnu/packages/syncthing.scm (go-github-com-golang-protobuf-proto): New
variable.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index e5b447b0b3..904f32fc52 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1953,3 +1953,30 @@ approximate quantiles over an unbounded data stream within low memory and CPU
 bounds.")
       (home-page "https://github.com/beorn7/perks")
       (license expat))))
+
+(define-public go-github-com-golang-protobuf-proto
+  (let ((commit "1e59b77b52bf8e4b449a57e6f79f21226d571845")
+        (revision "0"))
+    (package
+      (name "go-github-com-golang-protobuf-proto")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                       (url "https://github.com/golang/protobuf.git")
+                       (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "19bkh81wnp6njg3931wky6hsnnl2d1ig20vfjxpv450sd3k6yys8"))))
+      (build-system go-build-system)
+      (arguments
+       '(#:import-path "github.com/golang/protobuf/proto"
+         #:unpack-path "github.com/golang/protobuf"
+         #:tests? #f ; requires unpackaged golang.org/x/sync/errgroup
+         ))
+      (synopsis "Go support for Protocol Buffers")
+      (description "This package provides Go support for the Protocol Buffers
+data serialization format.")
+      (home-page "https://github.com/golang/protobuf")
+      (license bsd-3))))