summary refs log tree commit diff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 20:26:22 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:54 -0400
commit503802ab91ee3b208b0ea69d3ec0f35ea7328ebc (patch)
treeeff3e2b2153d67fadc04ed3450694e80feab25e8 /gnu/packages/syncthing.scm
parentcca22eb31a23b77e7b5f878a23daec89b9537ba8 (diff)
downloadguix-503802ab91ee3b208b0ea69d3ec0f35ea7328ebc.tar.gz
gnu: Add go-github-com-gogo-protobuf-union.
* gnu/packages/syncthing.scm (go-github-com-gogo-protobuf-union): New variable.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index c688bbc7ae..3272f7fdd5 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -189,6 +189,31 @@ structs in the Go programming language.")
       (home-page "https://github.com/gobwas/glob")
       (license expat))))
 
+(define* (go-github-com-gogo-protobuf-union
+           #:optional (packages (list go-github-com-gogo-protobuf
+                                      go-github-com-gogo-protobuf-protoc-gen-gogo)))
+  (package
+    (name "go-github-com-gogo-protobuf-union")
+    (version (package-version go-github-com-gogo-protobuf))
+    (source #f)
+    (build-system trivial-build-system)
+    (arguments
+     '(#:modules ((guix build union))
+       #:builder (begin
+                   (use-modules (ice-9 match)
+                                (guix build union))
+                   (match %build-inputs
+                     (((names . directories) ...)
+                      (union-build (assoc-ref %outputs "out")
+                                   directories))))))
+    (inputs (map (lambda (package)
+                   (list (package-name package) package))
+                 packages))
+    (synopsis "Union of Go protobuf libraries")
+    (description "This is a union of Go protobuf libraries")
+    (home-page (package-home-page go-github-com-gogo-protobuf))
+    (license (package-license go-github-com-gogo-protobuf))))
+
 (define-public go-github-com-gogo-protobuf
   (let ((commit "efccd33a0c20aa078705571d5ddbfa14c8395a63")
         (revision "0"))