summary refs log tree commit diff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 20:15:06 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:52 -0400
commitdb64cb4010c43ffa0f942f932f6e0faf4ea24cab (patch)
tree10deaaa4dd226cc2ddfc89af1673076528ec61c2 /gnu/packages/syncthing.scm
parent6deb73c493d93accaf2fae029747b4df2d80874d (diff)
downloadguix-db64cb4010c43ffa0f942f932f6e0faf4ea24cab.tar.gz
gnu: Add go-github-com-ccding-go-stun.
* gnu/packages/syncthing.scm (go-github-com-ccding-go-stun): New variable.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 503da81c43..2bea82f92c 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1244,6 +1244,31 @@ virtual connections from a single physical connection.")
       (home-page "https://github.com/AudriusButkevicius/pfilter")
       (license expat))))
 
+(define-public go-github-com-ccding-go-stun
+  (let ((commit "04a4eed61c57ecc9903f8983d1d2c17b88d2e9e1")
+        (revision "0"))
+    (package
+      (name "go-github-com-ccding-go-stun")
+      (version (git-version "0.0.0" revision commit))
+      (source
+        (origin
+          (method git-fetch)
+          (uri (git-reference
+                 (url "https://github.com/ccding/go-stun.git")
+                 (commit commit)))
+          (file-name (git-file-name name version))
+          (sha256
+           (base32
+            "09fgmkvm0vzinl3ifrixyyxk2c9hbahrja7i0ir400harzq3my10"))))
+      (build-system go-build-system)
+      (arguments
+       '(#:import-path "github.com/ccding/go-stun"))
+      (synopsis "STUN client implementation")
+      (description "Go-stun is a go implementation of the STUN client (RFC 3489
+and RFC 5389).")
+      (home-page "https://github.com/ccding/go-stun")
+      (license asl2.0))))
+
 (define-public go-github-com-petermattis-goid
   (let ((commit "3db12ebb2a599ba4a96bea1c17b61c2f78a40e02")
         (revision "0"))