summary refs log tree commit diff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2023-01-18 11:26:18 -0500
committerLeo Famulari <leo@famulari.name>2023-01-18 17:30:42 -0500
commita43f3e0697bd344895837308d23fe4aa90843920 (patch)
tree224740a40347c90d06143e3f303d5143575a43e3 /gnu/packages/syncthing.scm
parentfda2d75d8d886ac32e20b7c5cebff378f2e374b9 (diff)
downloadguix-a43f3e0697bd344895837308d23fe4aa90843920.tar.gz
gnu: Syncthing: Update to 1.23.0.
* gnu/packages/syncthing.scm (syncthing): Update to 1.23.0.
[arguments]: Build with Go 1.19.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 75ebf7c11f..74c25ed3ab 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -47,7 +47,7 @@
 (define-public syncthing
   (package
     (name "syncthing")
-    (version "1.20.4")
+    (version "1.23.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/syncthing/syncthing"
@@ -55,7 +55,7 @@
                                   "/syncthing-source-v" version ".tar.gz"))
               (sha256
                (base32
-                "1falkf3lv6x9avbcinqzndzix7mzl255hds1pcrw3sipsy2vfly1"))))
+                "0n7438vppr8yrq8k4lsacjr48m1l0bfc2wv7rbrsc5br5bfx6rhg"))))
     (build-system go-build-system)
     ;; The primary Syncthing executable goes to "out", while the auxiliary
     ;; server programs and utility tools go to "utils".  This reduces the size
@@ -65,6 +65,7 @@
      `(#:modules ((srfi srfi-26) ; for cut
                   (guix build utils)
                   (guix build go-build-system))
+       #:go ,go-1.19
        #:import-path "github.com/syncthing/syncthing"
        ;; We don't need to install the source code for end-user applications.
        #:install-source? #f