summary refs log tree commit diff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-03-12 15:09:14 -0400
committerLeo Famulari <leo@famulari.name>2019-03-14 15:34:26 -0400
commit9c359ff4455703536788d536e4e7cfb4ee285002 (patch)
tree26c2b802b344f3fe5cf4f971328ced9dc1293b7d /gnu/packages/syncthing.scm
parente3900a4d64e4bf6f426809d6bff058e5a2ae9bc8 (diff)
downloadguix-9c359ff4455703536788d536e4e7cfb4ee285002.tar.gz
gnu: Remove the various Go union meta-packages.
* gnu/packages/golang.scm (go-github-com-gogo-protobuf-union,
go-golang-org-x-crypto-union): Remove variables.
(go-golang-org-x-crypto-bcrypt, go-golang-org-x-crypto-blowfish,
go-golang-org-x-crypto-pbkdf2, go-golang-org-x-crypto-tea,
go-golang-org-x-crypto-xtea, go-golang-org-x-crypto-salsa20,
go-golang-org-x-crypto-twofish,)[arguments]: Remove obsolete
'make-gzip-archive-writable' phase.
(go-golang-org-x-crypto-ed25519)[arguments]: The phase
'make-gzip-archive-writable' belongs here now.
(go-github-com-multiformats-go-multihash)[native-inputs]: Remove
go-golang-org-x-crypto-union. Add go-golang-org-x-crypto-blake2s and
go-golang-org-x-crypto-sha3.
(go-github-com-libp2p-go-libp2p-peer)[native-inputs]: Remove
go-golang-org-x-crypto-union. Add go-golang-org-x-crypto-blake2s,
go-golang-org-x-crypto-ed25519, and go-golang-org-x-crypto-sha3.
(go-github-com-libp2p-go-libp2p-metrics)[native-inputs]: Remove
go-golang-org-x-crypto-union. Add go-golang-org-x-crypto-sha3,
go-golang-org-x-crypto-ed25519, and go-golang-org-x-crypto-blake2s.
(go-github-com-multiformats-go-multiaddr)[native-inputs]: Remove
go-golang-org-x-crypto-union. Add go-golang-org-x-crypto-sha3 and
go-golang-org-x-crypto-blake2s.
(go-github-com-multiformats-go-multiaddr-net)[native-inputs]: Remove
go-golang-org-x-crypto-union. Add go-golang-org-x-crypto-sha3 and
go-golang-org-x-crypto-blake2s.
* gnu/packages/ipfs.scm (go-github-com-ipfs-go-ipfs-api)[native-inputs]: Remove
go-golang-org-x-crypto-union. Add go-golang-org-x-crypto-blake2s,
go-golang-org-x-crypto-ed25519, and go-golang-org-x-crypto-sha3.
(gx)[native-inputs]: Remove go-golang-org-x-crypto-union. Add
go-golang-org-x-crypto-blake2s, go-golang-org-x-crypto-ed25519, and
go-golang-org-x-crypto-sha3.
(gx-go)[native-inputs]: Remove go-golang-org-x-crypto-union. Add
go-golang-org-x-crypto-blake2s, go-golang-org-x-crypto-ed25519, and
go-golang-org-x-crypto-sha3.
* gnu/packages/syncthing.scm: Remove go-golang-org-x-text-union,
go-golang-org-x-net-union, and go-github-com-vitrun-qart-union.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm82
1 files changed, 0 insertions, 82 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 5bb11b0400..90228e558a 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -555,33 +555,6 @@ environment")
       (home-page "https://github.com/thejerf/suture")
       (license expat))))
 
-(define* (go-github-com-vitrun-qart-union
-           #:optional (packages (list go-github-com-vitrun-qart-coding
-                                      go-github-com-vitrun-qart-gf256
-                                      go-github-com-vitrun-qart-qr)))
-  (package
-    (name "go-github-com-vitrun-qart")
-    (version (package-version go-github-com-vitrun-qart-qr))
-    (source #f)
-    (build-system trivial-build-system)
-    (arguments
-     '(#:modules ((guix build union))
-       #:builder (begin
-                   (use-modules (ice-9 match)
-                                (guix build union))
-                   (match %build-inputs
-                     (((names . directories) ...)
-                      (union-build (assoc-ref %outputs "out")
-                                   directories)
-                      #t)))))
-    (inputs (map (lambda (package)
-                   (list (package-name package) package))
-                 packages))
-    (synopsis "Union of qart libraries")
-    (description "This is a union of qart libraries.")
-    (home-page (package-home-page go-github-com-vitrun-qart-qr))
-    (license (package-license go-github-com-vitrun-qart-qr))))
-
 (define-public go-github-com-vitrun-qart-coding
   (let ((commit "bf64b92db6b05651d6c25a3dabf2d543b360c0aa")
         (revision "0"))
@@ -668,61 +641,6 @@ generation.")
       (home-page "https://github.com/vitrun/qart")
       (license bsd-3))))
 
-(define* (go-golang-org-x-net-union #:optional
-                                 (packages (list go-golang-org-x-net-ipv4
-                                                 go-golang-org-x-net-bpf
-                                                 go-golang-org-x-net-ipv6
-                                                 go-golang-org-x-net-proxy
-                                                 go-golang-org-x-net-internal-iana)))
-  (package
-    (name "go-golang-org-x-net")
-    (version (package-version go-golang-org-x-net-ipv4))
-    (source #f)
-    (build-system trivial-build-system)
-    (arguments
-     '(#:modules ((guix build union))
-       #:builder (begin
-                   (use-modules (ice-9 match)
-                                (guix build union))
-                   (match %build-inputs
-                     (((names . directories) ...)
-                      (union-build (assoc-ref %outputs "out")
-                                   directories)
-                      #t)))))
-    (inputs (map (lambda (package)
-                   (list (package-name package) package))
-                 packages))
-    (synopsis "Union of the Go net libraries")
-    (description "A union of the Golang net libraries.")
-    (home-page (package-home-page go-golang-org-x-net-ipv4))
-    (license (package-license go-golang-org-x-net-ipv4))))
-
-(define* (go-golang-org-x-text-union #:optional
-                                  (packages (list go-golang-org-x-text-transform
-                                                  go-golang-org-x-text-unicode-norm)))
-  (package
-    (name "go-golang-org-x-text")
-    (version (package-version go-golang-org-x-text-transform))
-    (source #f)
-    (build-system trivial-build-system)
-    (arguments
-     '(#:modules ((guix build union))
-       #:builder (begin
-                   (use-modules (ice-9 match)
-                                (guix build union))
-                   (match %build-inputs
-                     (((names . directories) ...)
-                      (union-build (assoc-ref %outputs "out")
-                                   directories)
-                      #t)))))
-    (inputs (map (lambda (package)
-                   (list (package-name package) package))
-                 packages))
-    (synopsis "Union of the Go text libraries")
-    (description "A union of the Golang text libraries.")
-    (home-page (package-home-page go-golang-org-x-text-transform))
-    (license (package-license go-golang-org-x-text-transform))))
-
 (define-public go-github-com-audriusbutkevicius-pfilter
   (let ((commit "9dca34a5b530bfc9843fa8aa2ff08ff9821032cb")
         (revision "2"))