summary refs log tree commit diff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-11-08 16:39:14 -0500
committerLeo Famulari <leo@famulari.name>2017-11-08 17:24:02 -0500
commit03b154f8004d8658a21c3c6f00553bf76c652dcd (patch)
treee58f21a97c391db32473e6a8b1ecca1511cbeaea /gnu/packages/syncthing.scm
parent52ff28e4aab21335d40dc63b69113c867c71c845 (diff)
downloadguix-03b154f8004d8658a21c3c6f00553bf76c652dcd.tar.gz
gnu: syncthing: Update to 0.14.40.
* gnu/packages/syncthing.scm (syncthing): Update to 0.14.40.
[inputs]: Add go-github-com-zillode-notify.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 94ec693cb6..615247f48d 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -28,7 +28,7 @@
 (define-public syncthing
   (package
     (name "syncthing")
-    (version "0.14.39")
+    (version "0.14.40")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/syncthing/syncthing"
@@ -36,7 +36,7 @@
                                   "/syncthing-source-v" version ".tar.gz"))
               (sha256
                (base32
-                "07mrvd3vq0p4f550dpq73xg1vpa2h7xxz7vq07sjw0whapknkw9f"))))
+                "044pjz3x3fgpbsbkzgf72ljpwvvsqfj8fm9cnz7l8293cw2ssq4f"))))
     (build-system go-build-system)
     ;; The primary Syncthing executable goes to "out", while the auxiliary
     ;; server programs and utility tools go to "utils".  This reduces the size
@@ -158,7 +158,8 @@
        ("go-golang-org-x-text" ,(go-golang-org-x-text-union))
        ("go-golang-org-x-time-rate" ,go-golang-org-x-time-rate)
        ("go-github-com-d4l3k-messagediff"
-        ,go-github-com-d4l3k-messagediff)))
+        ,go-github-com-d4l3k-messagediff)
+       ("go-github-com-zillode-notify" ,go-github-com-zillode-notify)))
     (synopsis "Decentralized continuous filesystem synchronization")
     (description "Syncthing is a peer-to-peer file synchronization tool that
 supports a wide variety of computing platforms.  It uses the Block Exchange