summary refs log tree commit diff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-01-28 20:01:39 -0500
committerLeo Famulari <leo@famulari.name>2018-02-08 15:18:20 -0500
commit13dca4a56e2e568f879d49fc9d83d55656bcff77 (patch)
tree9b0bc711c9f7c4e7e875e1218e27ef623cc1c12d /gnu/packages/syncthing.scm
parent270590bd69849c6a85e94d9dfb96657c1aa222c2 (diff)
downloadguix-13dca4a56e2e568f879d49fc9d83d55656bcff77.tar.gz
gnu: Add go-github-com-prometheus-procfs.
* gnu/packages/syncthing.scm (go-github-com-prometheus-procfs): New variable.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index e7c6477313..a8581ec25e 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -2081,3 +2081,27 @@ message streaming.")
 Prometheus metrics.")
       (home-page "https://github.com/prometheus/common")
       (license asl2.0))))
+
+(define-public go-github-com-prometheus-procfs
+  (let ((commit "b15cd069a83443be3154b719d0cc9fe8117f09fb")
+        (revision "0"))
+    (package
+      (name "go-github-com-prometheus-procfs")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                       (url "https://github.com/prometheus/procfs.git")
+                       (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1cr45wg2m40bj2za8f32mq09rjlcnk5kfam0h0hr8wcb015k4wxj"))))
+      (build-system go-build-system)
+      (arguments
+       '(#:import-path "github.com/prometheus/procfs"))
+      (synopsis "Go library for reading @file{/proc}")
+      (description "This Go package @code{procfs} provides functions to retrieve
+system, kernel and process metrics from the pseudo-filesystem @file{/proc}.")
+      (home-page "https://github.com/prometheus/procfs")
+      (license asl2.0))))