summary refs log tree commit diff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-07-12 11:23:24 -0400
committerLeo Famulari <leo@famulari.name>2018-07-12 14:17:07 -0400
commitfd115bee31d04f1277560b82bb982e6aa19fc977 (patch)
tree420d95742837f44f9edb9d9967b58141633810fa /gnu/packages/syncthing.scm
parente81c952a4da21c7772f8104f4fcc44af3f403daf (diff)
downloadguix-fd115bee31d04f1277560b82bb982e6aa19fc977.tar.gz
gnu: Syncthing: Fix a crash bug.
* gnu/packages/patches/syncthing-fix-crash.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/syncthing.scm (syncthing)[source]: Use it.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 14e83b5861..4c0bceedf6 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -24,6 +24,7 @@
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix licenses)
+  #:use-module (gnu packages)
   #:use-module (gnu packages golang))
 
 (define-public syncthing
@@ -35,6 +36,7 @@
               (uri (string-append "https://github.com/syncthing/syncthing"
                                   "/releases/download/v" version
                                   "/syncthing-source-v" version ".tar.gz"))
+              (patches (search-patches "syncthing-fix-crash.patch"))
               (sha256
                (base32
                 "0bxkm5jlj6l4gai23bg0y31brr80r9qllh1rdg29pahjn0c2b4ml"))